ERG mode not working with new Watopia expansion update

ERG mode not working at all. Will not engage. I’ve had ERG mode drops in the past but this is different - ERG always re-activates. Tried multiple restarts and routes etc. to try and get it working. Currently using an iMac desktop computer with ant+ dongle for cadence and HR and using Bluetooth for Cycleops Magnus trainer. Have not had ERG mode issues in 18 months of use with multiple Zwift software updates. Tried ERG mode using iPad with older version of Zwift and works fine. Something about the update my setup does not like. Anyone else having issues?

I am having a similar problem, ERG is not responding correctly/at all. Only thing I changed today from yesterday was updating zwift. Difference: IPad/iOS, Original Kickr.

1 Like

Just sent Zwift my log files, they’re looking into it. Sorry to hear you’re having issues but glad to hear I’m not the only one. In the meantime, is your trainer’s firmware up to date and calibrated? This was one of their suggestions, though I had already taken a crack at that. My setup was updated and calibrated but still had issues.

Firmware updated on the trainer here. Just went through all of it over the last hour. Only thing I changed from yesterday to today was the update of Zwift.

Is this an iOS thing or an Android thing? Or both?

Same Here. ERG mode not working, no resistance changes as well after the update.
Using Kickr Gen1.

1 Like

Hi all,

We’ve confirmed an issue with Saris Trainers in ERG mode on platforms Mac, iOS, and Apple TV. If you are experiencing issues on a different platform or with a different trainer, please open a support inquiry and we can investigate further.

Thanks all!

1 Like

Me too! It’s super frustrating.

Kickr 2016. IPad Pro

All, I did a reset on the Bluetooth module on my desktop (as per Zwift support direction) and did a reboot on the computer, ERG mode back in business.

ERG mode worked all along using ANT+ connection, BLE connection failed.

Same problem with Elite Drivo, no resistance changes at all. I’m using Ipad. Ticket opened
Thanks

Same problem on Cyclops Hammer (Apple TV).

Ha, nevermind, my original problem is back. No response from ERG mode during TOW stage 3 group workout this morning. Worked temporarily yesterday. BLE communication issue

Same problem here. Using iOS on iPad with a Cycleops Hammer. ERG mode doesn’t work, and it doesn’t recognize inclines even with trainer difficulty maxed out (0% feels the same as 10%). I’ve calibrated the trainer using the Rouvy app and the problem persists. I tried working out in the Rouvy App and ERG works perfectly through that app, so this seems to be a Zwift problem.

1 Like

Updated yesterday and did a free ride, during which I calibrated my CycleOps M2 with Rouvy. Everything seemed fine.

Today when I did Tour Of Watopia Stage 3, ERG did not engage and I needed to do a lot of shifting and cadence changes to have a chance of hitting the target wattage.

I’m having this issue with Wahoo Kickr (original) and AppleTV. Tried to submit a support inquiry but it’s been stuck “verifying” for an hour.

Having the same problem - iOS App, MacOSX app both not controlling resistance.

When I use the wahoo fitness app I can control resistance perfectly. Where can I complain to zwift. This is extremely irritating. I’ve spend about 2 hours trying to fix this issue.

1 Like

Daniel, contact Zwift support through the myzwift website under the support tab. Currently no workarounds for this issue. They are working on a fix.

Send in your log files to Zwift, they are working on the issue.
Triple tap the Zwift logo on the welcome page, and it will show the log files. Select all of them and hit ok, and send them off

Hey Jay, sorry for the troubles.
This issue doesn’t affect Android, but looks like you posted in the Android Beta area of forum.
I’ll see if we can move this issue to the regular game area.
-Will