Erg Mode Long Delay and Getting Stuck

I have an intermittent issue with ERG mode where there is a delay between resistance changes and sometimes it just doesn’t change at all. I’m using a Wattbike Atom which has the latest firmware and Zwift running on a fairly new Windows 10 core i5 8GB RAM laptop with a fast internet connection. I have tried both Ant+ and Bluetooth connections both have the same issue. Tested with the Wattbike app - no issues.

Zwift support sent a link to trouble shooting but I tried everything there and I still have the issue :frowning:

I also tried with an Apple Mac, same problem with Ant+ will test Mac with Bluetooth next, after that I’m out of ideas.

Also reached out to Wattbike - not much from them yet but they did tell me that the sensor/pickup is in the centre of the bike so placing the Ant+ dongle under the bike in the middle would be optimum.

So I tested with a MacBook Pro and Bluetooth - no issues at all, luckily I have an old 2012 Mac that I can use.

Giving up on trying to resolve Windows issues, hopefully there will be a fix in the future either from Zwift or Microsoft…

have you tried connecting via bluetooth using the companion app on your windows set up?

Hi Chris, no I haven’t tried that, I’ll give it a go - thanks