ERG mode for controlling smart trainer (Vortex Smart) when powermeter is paired to an other powermeter (Garmin Vector)


(Philip Morel) #1

Hi,

As I often have > 5% difference in power between the Vortex Smart (too high, up to 30w difference @400w) and my Garmin Vector pedals powermeter, I have to save my workout on my Garmin520 and discard the Zwift one since the TSS is wrong when uploaded in Training Peaks. Moreoever I’m not able to do my intervals at a given wattage because of this 5% deviation.

I can pair my Vectors with Zwift to get accurate power reading in Zwift, and pair my Smart trainer with Zwift for speed/cadence.

The drawback is that I cannot have Zwift to control the resistance of my Smart Trainer (ERG mode) when I do a workout.

Is there a way of doing so?

Cheers

Philip


(Noel Nunkovich *USMES*) #2

There presently is no way to do this. When workout mode was first released those of us with power meters and smart trainers reported exactly this problem. Zwift’s answer was to disable Erg mode during workouts if a power meter and a smart trainer are both paired to the program. I suspect (and sincerely hope) that is a temporary fix but for the moment you have to choose between erg mode and an less accurate power meter or power meter and no erg mode.


(A Simashin (B)) #3

Cmon guys go here - https://support.zwift.com/hc/en-us/community/posts/203524763-Control-smart-trainer-s-resistance-with-external-power-meter-important-for-Workout-Mode?page=2#comments

and Vote for it