Erg mode broken since latest update on android?


(joris) #1

It seems that erg mode in zwift stopped working on my kickr core. It works fine with the wahoo fitness app, so it’s not my trainer.

Looking at the play store there was a recent zwift update, which got installed today on my tablet, with some fixes for cycleops trainers.

Anybody else suffering from the same problem ? This is quite annoying when you want to do a workout, and you have to manually stay in the right power range.


(Eric) #2

I have the same problem…


(joris) #3

Doesn’t seem to happen on the windows version of zwift


(Jeff) #4

Yeah, ditto on snap. Didn’t see before starting same topic. Same resistance regardless of grade. Watts and speed all that changes in app. Worked ok before update.


(Hans) #5

Yes, same problem on Kickr Core '18.
All latest softwre/firmware installed. Not had any issues before last Zwift release


(Carl) #6

Same problem since March 8 update. Using kickr 18 and galaxy 8. Sim mode not working either. Game shows power but no resistance change in kickr.


(Nick) #7

Same here…can we get a fix plz.


(Patrick) #8

Same problem here. Wahoo Kickr with Samsung S9. Works fine on my PC but when connecting to my phone it wont control the resistance on ERG during workout.


(Susan) #9

I have the same problem. Wahoo Snap and group workouts worked fine in ERG mode automatically, with Zwift program running on my PC. Then one day I was dragging so used the pause button on my companion ap running on android tablet to turn ERG off. ERG has not worked since.

I’ve gone into Zwift before a workout, found the place to select ERG on, then joined the workout and still, ERG doesn’t work.

I’ve gone to manually turn ERG on after a group workout ends, log out of Zwift, and when I log back into Zwift again - ERG is again off.

It’s like since the ‘chose your world’ option was rolled out, I can’t use ERG doesn’t work? Anyone know how to fix this?


(Susan) #10

Incidentally, I submitted a ticket over it. Unfortunately, what I got was a couple of auto replies that indicated my message wasn’t actually read by a person. I stated I was on the most recent version of the trainer software, and the reply recommended I check to be sure I’m on the most recent version of the trainer software.
It’s tiring when everything is working fine, Zwift pushes an update that makes my setup not work correctly any more, and their response is to suggest you go find a solution elsewhere. I think I’d like a feature request be: please allow me to continue using prior versions of the software.


(Neil) #11

I had similar issues with my ERG mode not working during a workout, but the Zwift android update released yesterday has fixed it for me. Hopefully it will for you too.