Does Zwift work on Windows Vista?


(Chris Leather) #1

I have a spare PC in the garage with Windows Vista on it. It has plenty of memory and a decent processor, but the graphics card is only 256mb.

Anyway, Zwift refused to work on it. Looking up the min requirements it seems this could be down to either Vista or the graphics card (or both)

I have no issue buying a half decent graphics card to get this working, but upgrading the OS seems to much of a pain.

So, bottom line. Will Zwift work with Vista if all the other specs are fine?

Thanks,
Chris


(Jon Mayfield) #2

Zwift does not officially support Vista, however a few users are using Zwift on Vista 64bit (it must be 64bit). 

When you say it “refused to work” what specifically does that mean?  Did you get some error messages?


(Chris Leather) #3

Hi John,

Am running 64bit version and have tried turning off firewall etc.

The error is as follows:

Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: zwiftlauncher.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 5653e2a0
Problem Signature 04: System
Problem Signature 05: 2.0.0.0
Problem Signature 06: 53a127e2
Problem Signature 07: 3ab6
Problem Signature 08: 77
Problem Signature 09: System.InvalidOperationException
OS Version: 6.0.6002.2.2.0.256.6
Locale ID: 2057

Read our privacy statement:
http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409


(Eric C. (Zwift HQ)) #4

Hi Chris,

It looks like you might be on an older version of the .NET Framework (after a little Google-fu).

Make sure you are on Microsoft .NET 4.5 at the least and the try right-clicking on ZwiftLauncher and choosing “Run as Administrator.”


(Chris Leather) #5

Thanks Eric. 

I was sort of thinking it might have been something not up to date - then I remembered that Windows update had stopped working on that PC.

Will try a clean install tomorrow and see what happens when I’ve updated everything.


(Chris Leather) #6

OK, just did a clean install and running .NET 4.5.2. Using “Run as Administrator” but am unfortunately still getting the same error.


(Chris Leather) #7

I gave up and upgraded to Windows 7. Works fine now - well not too great on a 256mb card, but have a new 2gb card in the post…