Correcting Bluetooth Connectivity Issues After Treadmill Crash

Sharing an experience I had today here as I found myself stuck for a few hours and couldn’t find a lot of help with Google. Hopefully this saves others some time in the future…If this is the wrong forum feel free to merge/delete/move to the appropriate place.

TLDR version:

  • Horizon treadmills can occasionally reset themselves during a run (appearing like a power surge, as all of the lights flash and BT connections are lost)
  • If the treadmill is connected to Zwift during this reset the BT connection may become ‘locked’ and inoperable even when rebooting both BT and iOS device
  • As you cannot connect/disconnect the treadmill from the IOS bluetooth settings, you need a third party scanner app that can perform the disconnect for you so that Zwift can see the treadmill again. The BlueSee app worked for me in this instance.

Here’s the long story:
I was in the midst of a group run today when my treadmill shorted out. My Horizon 7.8AT has the occasional (once per 100 miles or so) hiccup where the entire unit will reset itself mid-activity, effectively rebooting the machine and losing all connectivity. At absolute worst a quick unplug and replug will fix the issue, and I can continue on (albeit 30 seconds or so behind whomever I was pacing with.)

Today was different, however. After the flash of the lights and my avatar becoming a statue on screen, the unplug treadmill trick wouldn’t work. No sign of the treadmill on the pairing screen. Restarted Zwift, no love. Rebooted iPad, nothing. I even went as far as factory resetting the treadmill via the hidden maintenance menu. Nope.

Panic washing over me, I decided to check and see if my phone could connect to the treadmill - fired up Zwift, and there it is on the pairing screen, instantly connecting. Okay, so the treadmill can talk to other devices, just not my iPad.

I end up doing a factory reset on the iPad and then restoring from backup to see if that will make a difference. An hour of pained waiting later, nope, nothing on the pairing screen. I take the iPad to my garage to connect to a pair of bluetooth headphones - no problem. So the treadmill is sending a signal, the iPad is receiving signals, the two just can’t connect to each other. Hmm…

Puzzled, I ended up finding a Bluetooth scanner app called “BlueSee” which lets you scan the local area for BT signals. I figure at least I can rule out a hardware issue that way. I put that on the iPad, fire it up, and immediately it finds the treadmill. Zwift still shows nothing. Okay, so whatever is going on is clearly a software issue, not hardware. I use the “connect” button for the treadmill via the app. It says “connected”, though Zwift still shows nothing. I then go back to the BlueSee app and disconnect, and, boom, like magic, Zwift can suddenly see the treadmill again. Did a short test and speed was coming through correctly after pairing.

Not sure what the root cause of the issue here was or why even factory resetting both devices (including a fresh install of Zwift) didn’t make a difference. My hypothesis is that the crash of the treadmill corrupted some Bluetooth connection details in the backend of the iPad. The factory restore just brought back the same cached information, and so Zwift was still unable to see the connection. And, because there is no way to “disconnect” or “forget” a Horizon treadmill from either the iOS menu or Zwift itself, it was basically invisible in the game. Thankfully this trick with the scanner app worked or I would be out shopping a new iPad, treadmill, or both!

I think the chances of this happening to anybody are slim thankfully.
Great work by yourself to figure it out.
I suspect your treadmill has some sort of fault as these surges you are getting currently shouldn’t be.

I’d be livid if it happened to me as I’m a bit of a data nerd and the disconnects would be adding to your average pace.

You’re right, likely a very rare issue!

I replaced the whole head unit earlier this year under warranty for some fried buttons. That had solved most of the electrical gremlins, at least for a few months. Have to say the repeated issues have me hesitant about recommending this treadmill to any Zwifters despite the fact it works great 99% of the time.

Perhaps not that rare!
I have a similar issue. Life Fitness T3 connect treadmill which up until last week would connect automatically as it has done every week for 4 years. But now zwift isn’t picking up the treadmill?
i reinstalled the life fitness connect app to reawaken the connections and was able to connect the treadmill to the app on my phone no problem. But zwift still not showing?
Any thoughts anyone?

Have seen multiple reports of this across Facebook the last few days since the last release. There is also a post on the “known issues” forum too: Zwift not connecting via Bluetooth to TRUE Performance 800, Landice L7 Treadmills [January 2023] - #11

Rumour has it there is a patch to correct this coming out but I haven’t seen anything official. If you’ve got a pod or alternative method of connecting that may be your best bet…Sorry not to have better news!

Thanks for your reply. I’ll be cycling over next few weeks instead. Tacx connects no problem still. and hope it may resolve itself.


Thank you, that was helpful for me too!

I have the Horizon 7.8 and mine had done this (loosing blue tooth) 3-4 times in a month that I have owned it. I have found it happens when i place my hands near the hand grips heart rate sensors when i adjust the speed or incline wheels. and I also feel like it may be a static electricity situation I vaguely remember a possible static shock the last time LOL … its dry here in MI winter… Ive been using the other buttons on the console for the last week.