Connecting apple watch for heart rate

apple watch heart rate monitor takes multiple restarts to get connected. please update. expect this to work better for a $20 subscription.

If you search the Forum I think you will find some other threads on this topic. My understanding is that this is an Apple issue, not a Zwift issue.

1 Like

Have a read of this - the watch app needs some big revisions and isn’t currently available in the watch’s App Store: Upcoming Changes to Supported Operating Systems [December 2021]

No news on when the watch app will be looked at again.


wierd. downloaded the watch apps a few months ago… still feel it should be contually brought up until a solution is found

Dedicated heart rate monitors designed to work with third-party apps over Bluetooth LE are the recommended way to bring your HRM data into Zwift.

Historically speaking - fitness tracker watches used to be designed to work well with that brand’s own app over their own proprietary flavor of Bluetooth or ANT, but they did not necessarily broadcast HR data in a way that third party apps like Zwift could use. Apple Watch is one of those fitness watches that’s not worked well, but the same applies for other manufacturers too.

Over time, fitness watch brands have shifted to open wireless protocols so HR data can be read by third party apps. However - this doesn’t help people who own the millions of older watches out in the wild that were designed before the shift to open protocols.

I overcome that problem with an app for iPhone / Watch called Echo. Works really well broadcasting HR to Zwift on my ATV.

thanks, will give that a try

Any update on this? Still doesn’t seem to work. I’ve tried all the recommendations here and elsewhere on the net, but nothing seems to work. At times it connects initially, but no data goes through and it eventually disconnects. It’s a mix of logout/login, reinstall, restart, to even get the initial connect again at that point.

Apple watch is officially not supported by Zwift (dropped some years ago). But should come again “zoon”.