Connected Bluetooth Device shows No Speed or Cadence on Android

I have a Bluetooth BLE speed and cadence sensor that I use with both my Samsung Note 8 (Android) and a Windows 10 laptop.

I’d like to get the sensor to work on the Android Phone. The sensor connects and is visible to Zwift (Android) and I select the same classic trainer selected when I use the Laptop (CycleOps Jet Fluid), yet with a strong connection, Zwift Android shows 0 MPH speed and obviously 0 power. The same sensor, wheel size, and trainer settings work flawlessly via built in Bluetooth on the Windows laptop.

I was starting to think it was the sensor but confirmed that it works well with the laptop. And the sensor will connect to Wahoo Fitness on the Android Note 8 phone and show a valid speed in that app, so the error is with Zwift Android. (I’ve obviously confirmed that only one app is running at one time on the phone, GPS is on, and the laptop is off when I’m trying the Android configuration).

I just think this is an error/current limitation of Zwift Android. However resolving this issue would give Zwift Android users more umm… mobility!

PS I also wanted to add that this Bluetooth Sensor worked earlier this year with an earlier beta version of Zwift Android (February/March 2019) I had not tried it again until recently.

This issue has been resolved with the December 2019 update to the Android app.