Companion App - Workout Page Blank [SOLVED]

I have done two of the Rowe & King workouts this week, on both occations the workout screen in the companion app has failed to show the workout. This has meant no method to adjust the % bias or to enable/disable ERG mode. This isn’t a big issue, and only seemed to happen to a few of us.

I restarted the app and the phone and it still continued to show ‘blank’.
I have done other workouts and the workout screen on the app has been fine.
This is from an Android phone.

Hi @Woody_BRRT

Thanks for flagging this up. I’ll pass it along to our bug testers to see if they can reproduce it.

Also - we appreciate screenshots to illustrate what’s happening on your end.


We found out the problem, and hope to have it fixed for your next week’s Rowe & King workout sessions. Would you loop back then and let us know it’s working?

No worries, of course I will.
Appreciate you getting back so soon, glad you found and hopefully squashed the bug!

1 Like

@shooj Still not showing the Rowe & King workout screen.

@shooj This is still happening for me (or something with the same symptoms) about 75% of the time. Even restarting the companion app does not fix the issue or switching tab to map view and back. I’m using a Nexus 7 to run the companion app if any old version of Android makes a difference.

Does Companion kick over into game mode at all?
Or are you saying that the workout page specifically isn’t showing data?

One thing that gets in the way of Companion “seeing” that you’re in a session is if you have a VPN running (either on your the device running the game app, or the device running the Companion app). Please verify there’s no VPN interering?

Yes, the Companion app does automatically switch to game mode and selects the Workout tab when starting a workout, but the tab is empty just as the OP reported.

It’s just the workout tab that does not work, the map view is working correctly. I don’t have a VPN running, but do have one installed (but that shouldn’t make a difference).

Thanks for the clarification.

Trying to isolate where the disconnect is happening. Do you remember which training plan and the specific workout where this occurred?

Does it happen in other workouts within that plan?

I have the same problem since a couple of weeks ago. The other “tabs” are working fine but the Workout tab is all blank
Happened at several of the ZA workouts and today at the Anaerobic Capacity Into V02 at 16:20 CET
Running Zwift on Windows 10 laptop and Companion app on Android phone

Hi, this happened to me today in the THU. EPOC by GCN. I’ve only done a few workouts but everyone up to this one has worked perfectly. Using Windows 10 pc, and champion on android phone. Prior to the workout I’d been warming up in Wattopia and auto joined the workout at the 5 min to go point when it does the 30 sec countdown and auto swaps. I do this all the time so nothing different. The only difference was I’d just gone under and arch and obtained a power up that I never used and it was still there when I swapped back to the map screen during the workout trying to fix the blank workout screen.