Companion App Not Showing Workouts [February 2023] [3.43]

I updated Zwift on my MacBook and the Companion App over the weekend when the latest update had been pushed. On Saturday I used the workout screen via the Companion App with no issues. I didn’t ride Sunday and on Monday using my same computer and phone, when I loaded my ride/workout the dark workout screen never loaded. Both my computer and phone are on the same home network. This is the first time I’ve had this issue and it’s only been since updating. I can still load and ride the workouts via Zwift, but the Companion App doesn’t seem to load…

I am running Zwift Companion App version 3.43.0 and Zwift version 1.33.0

Is the app itself not loading? Or is the Workout screen not working as expected? Mine has looked like this for about a week, during Workouts:

I started another thread to try and get it addressed, but curious if you’re having the same problem?

Hi all, for my last three workouts (so, about a week), the Companion app is not showing my typical workout screen. Instead of the plan, target wattage, ERG mode, HR, etc. it is showing this:

Another user posted something similar and said it was the running workout screen, but there is no runner “icon” on mine so I’m a bit lost. The way the numbers are changing doesn’t seem to make any sense either.

My setup is a KICKRsnap, TICKRx hr monitor, and RPMcadence sensor connected via Bluetooth to an iPad, Companion version 3.43.0.

Cycle workout display is not wotking at all
I saw a few posts about this, but no answers

The normal Companion window that is white showing ride data is working, but when I load my workout from my coach the screen never turns black and shows the timed segments. Zwift running on my computer or iPad works fine and I can see the workout there, but the Companion App doesn’t ever show the workout page.

1 Like

Confirming I’m seeing the same thing.

Zwift on Windows 10
CA on iOS 16.2
iPhone 12 Mini

Loaded workout from training peaks and observing the same bug as the screenshots above.

Same here, iOS ZCA workout screen is all jacked up on both my iPhone SE2 and iPad Mini 6. I run Zwift on an ATV 4K G2 and all devices are up-to-date with latest firmwares and the recent Zwift and ZCA updates. This started occurring for me after last week’s Zwift & ZCA updates.

It appears to me that the same time value is being mapped to multiple fields on the workout page, we’re all seeing the same (incorrect, static) “Finish In 1:50:24” in the top-right, “Workout Title” in the top-left (instead of the actual workout title), and no graphical display at all of the the workouts’ intervals nor controls for Erg mode, etc.

@shooj can you confirm that you’re aware of this issue? Nobody seems to be voting up the thread and I haven’t seen any “official” replies on it in multiple threads, so just want to make sure ZHQ is tracking.


New bug over the last week or so.

During a workout, companion app fails properly to show what’s going on. Screenshot attached.

Also (longer term bug): the u-turn button on companion has no effect.

Zwift on ATV, current version.
Companion on iPhone, current version.


Same issue here. During the weekend no issues with the workout screen in the companion app. Yesterday no workout info loaded. I have no printscreen, but it was exactly similar as what has been posted earlier. Also it showed the running icon.

My setup is Tacx Neo 2T connected via BT to Macbook pro.
Companion app on iOS16.2 (iPhone 11).
Zwift on Macbook pro on macOS 12.6.1.
Phone and Macbook on same WiFi network.

Same problem here.

1 Like

I did a workout today Friday, Feb 03. The workout loaded on my ZCA no problem. I didn’t do anything different, so I am not sure if Zwift resolved the issue on the backend because I haven’t seen any updates via the App Store?

since last update (for me 2 days ago, android 10), the workout screen doesn’t load correctly. tried close and reopen the app an nothing. all other screens were functional.

I’m having the same issue on iOS since the latest release . Any ideas ? Is this bug known @shooj ? Took this pic this morning confirmed I’m on latest update post Scotland map tried exiting and returning . I’m doing bike workout not running and it’s training peaks custom. Thx

Hi friends, for some reason the past two bike workouts I’ve done on Zwift, the companion app thinks I’m running. My workout loads fine on Zwift, but the workout tab on the companion app shows a little icon of a runner with only my running pace…even though I’m cycling. Doesn’t show my workout at all! I’ve been using Zwift for almost three years now and have never had this issue. It’s bonkers. Happens when using Zwift on my iPad and on my Apple TV. I tried deleting and reinstalling the companion app, but that didn’t work.

Anyone has the same issue? It started after the last update.

Different, but similar …

1 Like

I’m experiencing a similar, but not the same, issue. For the last three workouts the Companion app is showing this screen:

I looked at the screen for a while and determined that it must be a bug, because the information it was showing and how it was changing didn’t make any sense, but maybe it is the running workout screen (albeit without the runner icon).

FWIW I’m running a KICKR trainer, TICKRx hr monitor, and an RPMcadence sensor, all connected to an iPad via Bluetooth.

1 Like

I had the same issue last night.

The companion app also closes the workout sometimes, I’m presuming that is my home network though as its been happening for years, and then will reconnect. At one point the re-connected session showed the cycling workout correctly.

Very strange!


Any solution for that bug?

I am riding now and still experiencing it. Quite annoying.

Add me to this lucky group !

I posted on another thread but this seems to be the current one. Hopefully @shooj can advise if Zwift are working on this please ?

Fwiw Zwift is Mac (m1) , companion is iOS , I was on a kickr bike and I wasn’t running .