Companion app no longer adding events to calendar

I’ve always had issues with the Companion failing to put entries into my Google Calendar. It fails more often than not, but sometimes succeeds, for no obvious reason. Sometimes I’ve fixed it by successively subscribing to an event and unsubscribing again, till it worked. At the moment, nothing seems to do it. There was a time when Trey’s workaround of going from the overall event page to the category page for the event helped, but not at present. This on several devices including my current Samsung tablet and Pixel phone, but it happened on my previous ones too. From the hint in this thread, I’ve also just tried revoking permissions, restarting the app and reinstating them, but that didn’t help either.

It’s been broken almost a year at this point. Ridiculous really that existing features can just disappear and be forgotten about. Surely fixing inadvertent errors should take priority over new stuff.

Anyway you just have to do it manually, join the event then click the little alarm clock next to the time beneath the green/white tick (it’ll be greyed out).

I don’t think that works for me either, in terms of getting the ride into my calendar. Nothing does.

1 Like

I use a Samsung phone and tablet and, if you open up the participant list for the event and category of interest, and then join the event from there you should hopefully have everything added that you ask for.

I did have a problem creating calendar events when i had the Samsung Calendar app app disabled (actually not possible, so i revoked all permissions), preferring to use the Google Calendar. But you can’t set the Google Calendar as default, so calendar event creation accomplished nothing as the events went into a black hole. Once i restored Samsung Calendar permissions, instead disabling notifications from it, my Zwift events appeared, to then be synced with my Google Calendar, which i do use and from which i get my calendar notifications.

Thanks - this was really helpful. I don’t have the exact problem you described, but it does relate to Samsung calendar. I don’t use that app - I use Google. And I don’t even see the Samsung app normally - it’s not in my tablet’s list of apps, possibly because I’m using a third-party UI. I don’t care because I’m happy with Google.

But I managed to get in and see that the events are indeed going into the Samsung calendar. Grrrrr. Talk about unnecessary complications. What makes it worse is that my Pixel phone still isn’t reliable at getting Zwift events into the calendar either, probably because of the effect described in this thread where registering from the participants’ page works better.

So, the summary for me is (1) Never register on the tablet, because it’s broken by Samsung, and (2) On the phone, register on the participants’ page.

We’ll see how that goes. It’s working at present.

And yes, I’ve seen several pages saying how nice the Samsung calendar UI is. But I only need good enough, which Google is, and I don’t have the spare time to figure out how to fix the functions broken in order to get an unnecessarily-nice UI. I just don’t care. I want it to work as simply as possible, which means no junkware apps, at least unless they are optional. I may buy something else next time…

Rant over. This page may help other Samsung sufferers, though it didn’t help me:

One problem I had solved before and forgotten, is that on my iPhone, I was never able to sync to my Exchange company calendar. By changing my default to google calendar, the process works fine. So for those having issues, it may be worth trying a different calendar if you can.

Yes, I think the Samsung issue is related to that, and not being able to make the Google calendar fully default because the Samsung one is forced on us, and then we have to rely on the synchronisation with Google working. So far I haven’t bothered to investigate further, because my workaround of using my non-Samsung phone instead is enough.

Have you already tried going to Settings > Apps, select the Samsung calendar app, and then select Disable?

Tim, a few messages upthread, suggests that that is not a very good idea?

Given that Colin identified a work around to this problem in Feb 22 that should have made it extremely easy for the developers to fix, it is rather amazing this is still broken in Feb 23.

Zwift … c’mon!

It’s actually been working for me for at least a few weeks, so probably with the January ZCA update.

Working ok here on Android.

I know there’s multiple threads on adding events to calendar issues, but this seems the best place to ask….

Has anyone been able to use the companion app (apple or android) to add events to an outlook calendar?

Its added them to my google calendar, which is my default in outlook no problem


Ahhh… So you have synced your google calendar to outlook?

yeah, my google calendar is synced to outlook, as well as to an app on all my mobile devices

1 Like

“Set as default” always resets to off for me. So the only way to get calendar events is to specifically click on the tiny calendar/clock icons after adding an event, which then pops up the “Reminder Settings” dialogue box. I can then “Set as Default” and save and it will put it on my calendar, but it will not stick. I need to do that every time.

At one point a long time ago, this worked. I could set the default to on and then all the events would be added to the calendar properly.