Companion App 3.40.0 on Android has text gaps, crashes, buggy behavior [September 2022]

Have several issues with the app, began two days/two rides ago. Running on a Samsung Galaxy Tab A, Android 11, up to date. App was working fine before then, no issues, and didn’t install any software or make changes on the tablet between good app and bad app. I have uninstalled and reinstalled the app, no change.

-Font/text is messed up. Will try to attach screen shots, but there are random spaces between letter in words. Big spaces.
-App is either disconnecting from the game/activity, or straight up crashing and restarting. Hard to tell which, as the effect is that it locks up, then kicks back to home page, then reconnects to the Activity. Multiple times, maybe once per minute.
-App is also freezing/thawing when it’s not crashing as above. Click a button, power up, uturn, etc, it might occur a minute later.

It seems like it starts out okay (except the font, that’s goofy from the start), but then gets buggy throughout. That’s with an N of two, both 90+ min rides. All other apps on the tablet seem to be working okay.

(having trouble attaching an image using the app to post this, I’ll post this and then a reply hopefully with pics. For the moment, imagine the home screen, lists of rider names, etc, all looking like this: ACT IVI TIES)

1 Like

Hey, and looking at those two shots now…I’d say it’s the T that’s the culprit. Or I should say CULPRI T.

Everything is fine with the app on my phone, FYI. But I use the tablet and it’s bigger screen for the companion app :frowning:

Also works okay on my wife’s Android 10 tablet.

I have the same issue with the text being messed up on my android phone. Thought it could be the phone at first but came here to see if anyone else had the same issue. I am also running android 11.


Well, yay, in the sense that it’s not just me and there might be a solution they can find. :slight_smile:

Are you having crashing/disconnecting problems with the companion app too, or just the text? I can’t tell if they’re related, but they showed up the same time.

1 Like

Same issue.


I think i did have it crash during a pace partner ride last week but wasn’t sure if it was connected either, Hopefully doing a slightly longer ride over the weekend so will see what happens and report back.

1 Like

I’m really tired !! The last update 3.40.00 caused that.

I have an email exchange started with Julio from Support as well, so I’ll keep this thread posted with anything we find out.

1 Like

And if it helps any Zwift Support staffers seeing this, I’ve found the same gaps in my Activities list happening occasionally with the letter W. All the others above seem to happen with T’s. In Activities, it’s W’s, but not all of them.

1 Like

And I have App Version 3.40.0 (1456). Server version 1.299.0

Hello all,

Thank you for flagging this up. We are seeing multiple reports of the “tex t” issue on some Android devices running Zwift Companion version 3.40.0. I’ve written up the bug and will update as I get more information.

Crashes and performance issues seem to be more rare, but we’ll be looking into those as well. Please don’t hesitate to reach out to Support if you’re being prevented from getting your ride in.


Rowdy, thank you so much :slight_smile: I’m away from home for the weekend, but I’ll be able to check hopefully Sunday night, try to see if the crashing is just cotemporaneous, or if they’re part of the same problem. I’ll ride and check with multiple devices.

FYI, here’s the central bit of an email I just got from support on the matter:

“At this time, we’re aware of several known issues with Zwift Academy Road. And that the long words in the Zwift Companion App are one of them but we working to fix it.”

So, hopefully progress. I haven’t been doing anything with ZAR, but apparently it’s janking with the whole app.

Anyone else got gaps in the headers lettering on the companion app?
Ive tried uninstalling,then re installing but still the same.

Then the topic should be moved to the known issues.

Running Companion App 3.40.0 on Android 12. Noticed today that the heart rate text is split onto two lines with the third digit below the first two.

Also on the About screen of the companion app you’re still using the V1.0 version of the Zwift logo.

The trailing number on HR I think is a separate issue–there were people reporting about that since the font change, as far as I can tell. That’s more a screen layout and font spacing issue, different from the gaps in words. (Still a problem, of course, just a different one :slight_smile: