Can't update Zwift Hub firmware in Companion app [Android and iOS]

That is why there are two sections - one for paired devices (this is where previously paired devices show up) and available devices (not previously paired but scanning to be paired)

It looks like some kind of a bug for me.

Do you have a different android device you could install the CA on and try that?

I have tryed three diferent Samsung phones, no luck at all.
Maybe its only for Samsung phones.

1 Like

Same with Huawei :frowning:

Hi @Martins_Odins
Something that hasn’t been discussed yet: the Companion app requires that you give it permission to Location access in the OS settings. This permission allows the app to use the Bluetooth radio hardware so the app can “see” the trainer’s signals properly.

In Android 10 and older - allow permissions to “Locations.”
In Android 11 and newer - you should allow permissions to “Nearby Devices.”

Would you go into Android OS Settings > Apps > Companion > Permissions > Location and double check the settings?

iPhone / iPad users: Apple implements Bluetooth permissions for iOS apps in a very similar way. If you’ve googled your way to this thread - please follow these instructions on Apple’s support site


Thanx you very much, nearby devices worked for me, such a stupid thing when you turn on bt and also you need to turn on nearby devices, i never used that option before.

1 Like


Thank you for coming back to let us know the Locations / Nearby Device permissions settings solved this problem.

Ride on!


I´m trying to update firmware for my Zwift Hub 191A. I use Zwift Companion and have it paired with my phone, with GPS activated.

Update is stuck at 0% “Waiting for bootloader”…

Any step I´m missing?

Thanks in advance.

Hi @Guillermo_Hernandez welcome to Zwift Companion.

I moved your post into this previous thread. Please see the first post and check your Locations permissions.

Also - you should not pair the trainer to your phone’s OS as a Bluetooth device as you would with Bluetooth earbuds. Instead - you only pair to the Companion app. Please confirm that’s the case?

Hi @shooj you moved my thread to a resolved thread. As this is closed I cannot interact with anybody. I have created this new thread as I do not know how to send private messages in this forum…

I already followed steps and cannot make it work. Location services are activated and not paired by bluetooth or Zwift app (today is on maintenance so this is not a problem).

I have a Samsung S9+ and Android 10).

I have recorded a video of the process, but cannot include any link on the post…

Unfortunately I can’t help you on your update issue but I can provide you infos about Links and PM: you have access to that only when you have reached the “member” status (trust level 2), that’s why you can’t do that for now…

I hope you can get your issue sorted though!

Hub is not paired with phone, just with app.

As someone from Zwift team recommended by e-mail…I have also tested trying with airplane mode and wifi/bluetooth enabled, disabling 5g. But same result.

I think it has to do with the app, because in the process it can connect but stucks at bootloader…I have latest version from 12 october.

Resolved! Tried in another device and worked…Seems mine has some security configuration that prevents upgrade.

1 Like

Thanks for letting us know, and glad that it’s working on a different device.

I am curious, though: is that Samsung a work-issued phone? What do you think is the security configuration blocking the app?

I think it may be my company security policies, as it has some firewall installed

1 Like

Didnt work

I did the new software update and now the hub connects to Bluetooth but no signal is sent and blue light blinks slowly and Zwift doesn’t have an answer.