Can't pair Power Meter w/Classic trainer


(Sean Ormerod) #1

Before the last update I had my Stages power meter working with the classic trainer option (with kurt kinetic). After the update it’s power meter or classic trainer in options?

This seems like a silly choice to have to choose when it worked fine before. Also my Stages is my cadence so now I no longer get real power and no cadence, so annoyed.

 


(Jon Mayfield) #2

Hi Seah, if you have a power meter paired there is no reason or benefit of telling Zwift what your classic trainer is, as Zwift does nothing with that information.   The only way you should be able to pair a classic trainer is if you’re using a speed sensor to generate virtual power readings.

 


(Sean Ormerod) #3

This doesn’t work as the option now has the speed sensor tied to the classic trainer option.

The option is as follows:

Power Meter OR Speed Sensore/Classic Traner

The software doesn’t move the avatar with the Power Meter enabled as it sees those metrics but cannot tell I’m moving as no speed data!

I again had no problem before the latest update and cannot fathom why the update would “unpair” every sensor I have. Regardless it should just be able to use any and all sensors to collect data. I have liked the product so far but big step back IMO.

If it’s not something I’m doing wrong then I am glad it’s free still or I would be canceling.


(Jon Mayfield) #4

I’m not sure I follow.  Don’t worry about the speed sensor. With a stages power meter paired you should have never been able to select speed sensor, and if you were able to then it was a bug.  Zwift does not need a speed sensor paired.  We don’t use it in your case.

Now, if you’ve paired your stages as the power meter (and no speed sensor) and you’re not getting any wattage data through, that sounds like an issue.  Is that the case?


(Sean Ormerod) #5

With the Stages paired Zwift doesn’t do anything I just sit at the side of the road and do not move. I assume this is because it doesn’t see any data that suggests movement “ie: speed”.

How would/does it calculate proper speed with only power and cadence?

As it stands Zwift is doesn’t work with the power meter as I have to chose classic trainer to get the speed sensor.


(Jon Mayfield) #6

With the power meter paired we use only watts to move your virtual mass up and down virtual slopes. Speed sensor is for users who haven’t spent money on a power meter, which is why we only let you pair one or the other. 

So you’re saying you just see 0 watts while you’re pedaling after pairing the power? Or do you see power data on screen while in the game on the side of the road, but you never move?  Sorry for the all the questions, but I’d like to understand what is going on and see if we can get you back on the virtual road.


(Sean Ormerod) #7

Okay it paired the cadence and power and nothing registered on Zwift but all worked flawless on my Garmin head.

I unistalled and deleted the Zwift folder. Then reinstalled Zwift. After update the sensors were all unpaired. I set about repairing and now it will see the Stages as power but not as candence. I only move in Zwift using speed/classic trainer combo. 

To much effort at this point its your latest update, period. I have been with you since this time last year but you have until the end of the free time and I’m gone. 

I have spent hours trouble shooting this as second level support I’m only disappointed I wasted this much time. Best of luck in the future!

 


(Sean Ormerod) #8

So after 3 more attempts I gave up on trying to get the avatar moving while using the power meter. After all the various attempts I have at least got cadence along with, speed/classic trainer working though.

I am disappointed though that:

  1. The game doesn’t work with the power meter

  2. That support gave up after my last post.

  3. That I started this post only after there wasn’t an answer after 24 hours to my support ticket.

I assume your busy but my work place would be on me for the level of service I’m experiencing. I’m on the fence about staying or not…

 


(Eric C. (Zwift HQ)) #9

EDIT - I see a ticket in our queue, actually. I’ll respond so that you can attach your log file to it for further inspection. Thanks!

Hi Sean,

Please remember that yesterday was a weekend and the office is typically closed. If you are having problems, generally the best course of action is to submit a support ticket.

Jon is our lead developer (and creator of the Zwift software in general) and was trying to help out without sending you onwards into the support queue which is currently experiencing extremely high demand at the moment.

At this point in time, unless we know exactly what is happening it’s hard to understand why pairing your Stages as a power meter isn’t working. So, please submit a support ticket to http://bit.ly/ZwiftSupport and include the latest log.txt file located in Documents\Zwift\Logs

This file can tell us a few more details (including what’s trying to pair) and we can troubleshoot further.

Thank you for your patience :slight_smile:


(Sean Ormerod) #10

I sent in the requested files through the ticket and have yet to receive any type of help or comment. Either the line up is that long to make this work or you just care about customers that much. 

Not being out doors riding is almost as sad as your customer support!


(Eric C. (Zwift HQ)) #11

Hi Sean,

I’m sorry for the delay but we are experiencing 3x the demand that we are used to and are working our way through each and every one of our requests as quickly as possible while still making sure we answer and help the user.

We thank you for your patience!


(Greg Lawther) #12

Over one year later, new to Zwift and am having exactly the same problem. Has a solution been found?


(Eric C. (Zwift HQ)) #13

Hi Greg,

The solution is to only pair your power meter. You ONLY NEED to specify a classic trainer if you have a speed sensor. This is because we need to know which VIRTUAL POWER curve to use in conjunction with the speed sensor so we can calculate the power being generated.

When you have a power meter, it tells us how much power you are generating and there is no need to calculate it based on your trainer. This is why, if you are using rollers, a power meter is your only real choice - because you have, possibly, the most accurate device giving us direct power data.

If you use your power meter, it doesn’t matter what kind of trainer you’re on.


(Greg Lawther) #14

I understand. I have paired only the power meter and the Zwift software finds it and recognizes it measures both power and cadence. It shows the unique ID of the Stages meter and says it is paired. It is just that when I ride the rider avatar just sits there at the side of the road fidgeting while others ride by.

 


(Sean Ormerod) #15

I was hoping this thread wouldn’t appear again I have handled things better I swear. Zwift is great still using it and it is great for the winter days!!

Two things:

 

  1. The issue you’re having with the PM is one I’ve had happen at least once a week since the last Stages firmware update. When sitting at the side of the road when peddling look at the info (top left) for the PM it should read zero. I have found it will read zero then once I start peddling even after the avatar has moved 1-2 hundred meters then suddenly stops that the data field changes to dashes. That is because the PM has stopped broadcasting to the computer. Until the last update simply rotating the crank woke it but now for some reason that’s changed. Now when that happens again sometimes 2-3 per week (I ride usually 5-6 times) I have to rotate the plastic battery cover on that stages and for no reason I have figured it pop’s back to life. Which you see on the screen data fields as they display a zero again instead of dashes. 

  2. A bit greedy but during beta we could pair both speed and PM on classic trainers or at least I could. I would think this would be great as a back up during training in case the PM has an issue be it dead battery or it stops transmitting.

 

Hope this helps, good riding! 


(Greg Lawther) #16

My issue is not quite the same, but similar. Despite trying at least a dozen times, my avatar has never moved from the side of the road, even when the software clearly shows that the power meter is paired. 


(Sean Ormerod) #17

Sorry I was hoping it would be a simple fix.