Can't pair both Power and Controllable signals separately [August 2021] [1.16.0]

@shooj, it wasn’t squashed after the last update. If you go back to thread you marked solved several people responded that they were still having issues.

1 Like
  1. windows 10
  2. bluetooth.
  3. I need to pair the power or the cadence first so zwift can see the controllable trainer.
  4. I can disconnect the power or the cadence after the controllable trainer is paired.

Tacx neo/Apple tv
Same problems as every one else.
My set up is now unusable as a reliable training device.
12/53, 80cadence, 10% hill and I weigh 100kg (I wish)
I am looking to switch back to the Tacx software.

No solution, no information, no apology.

Zwift you need to be up front and sort this, releasing upgrades that clearly have not been quality accessed is not acceptable.

On a positive note I seen the part of your system for taking my money is working fine!


Same configuration as Mr Dunbar, stopped working as a controllable trainer with road feel late last week after using it for a month (I’m a new user) so I assume due to this latest version release (V1.16.0).
Is there an estimated timeframe to fix this issue or is it possible to make the previous version (V1.15.1) available to users while it is being fixed/tested?

Same, cant connect pedals and controllable simultaneously, very sad, had to switch to another app.

Not sure if related, but people seem to be talking about many pairing related issues. When my HRM is selected in the pairing screen, it will briefly show the battery level, or when selected briefly show either 0bpm, or the current bpm, then will display “no signal” after that and never provide heart rate.
This symptom happens on 2 Windows 10 desktop machines.
The HRM DOES work on a Windows 10 laptop, and used to work on a Macbook pro, but that machine died since.
The HRM also works with the desktops through the companion app, though I would prefer to not HAVE to do that but will for now.
The Kickr Core works fine on all configurations(mostly old phone and old macbook had issues with over companion, unrelated).

I have tried 3 or 4 different bluetooth driver versions. Disabled firewall and virus protection. Reinstalled Zwift removing the Zwift Documents folder. Installing the battery of VC redistributables.

Machine details:

  1. HRM doesn’t work
    I5 6600k
    Nvidia 1070
    Gigabyte AC8260 PCI-E Wifi/Bluetooth 4.2 card

  2. HRM doesn’t work
    Nvidia 3090
    Intel WiFi 6 AX200 built in wireless chipset

  3. HRM works
    HP ZBook Studio G4
    AC 8265 wireless chipset

Burned hours on this, and chat support basically just said to try different drivers. They also said that “external BLE” wasn’t supported, though none of my wireless are really external, at least not USB. All are Bluetooth 4.2 or better. And the Kickr works fine.

What can we do about this?

  1. no
  2. yes
  3. yes
  4. yes

so pair my Tacx Neo 2T as power, then when the next screen loads, set it as the controllable trainer. click power and choose my power meter on my bike. Notice that Tacx trainer stays paired as controllable trainer. pair power meter as cadence. pair steering controller, HRM and go.

Similar for me, this “update” is still showing the bug introduced in May ?
Apple TV. Garmin V3 pedals, Polar HRM, Kinetic Road machine Control, Companion App iPhone 6s

Need to re-pair trainer for Power from Trainer first, then select V3 power pedals second for power and cadence
If I pair V3 pedals ( with are remembered on boot by default after boot) the trainer is NOT shown in the control section despite several minutes wait.

im not sure if this is the same issue, but when I am in Workout mode the cadence is all over the place, my Kickr v5 is not adjusting the resistance at all, so I have no idea what power I am doing so no point doing the workout. if in Just Ride mode, the trainer does not feel any different whether going up hill, down hill or flat. It was fine then one day not fine. I have unpaired and reset everything, it shows up as Controllable, but just cant seem to get them to talk to each other properly.


I’m running it on Apple TV, I can pair trainer (Kickr v5) and it says controllable. I dont have a second power meter. But the resistance isn’t changing when in ERG mode, and in Just Ride mode there is no change regardless of uphill or down.

1 Like

I have Kickr Bike and it will not even show Bluetooth on Controller (it did before the update in July) so I can’t use my steering function anymore. My computer is a MacBook Pro running Big Sur on the latest release. @shooj Please respond - getting frustrated that this controller issue continues - go back and look at the merge code from your git / bitbucket repository and determine the change that is causing the fault with controllers pairing with BlueTooth


my post recently got removed for calling them out for not having a VCS system in place and not running a diff before they commit their codes. (they said I was attacking too personally shrugs)

This isn’t a baseless claim as I’ve noticed they tend to have small visual related bugs whenever they launch new frames/wheels. This kind of error should have been weeded out when doing a proto build with a simple diff before checking in.

Zwift, is this constructive enough?

It is as simple as, shelve proto code → assign dev lead to look at the shelveset → commit after code review.

This will weed out all small errors before they even reach a hypothetical QA system.


I have Kurt Kinetic Smart Trainer. I was off Zwift for a few months. About 10 days ago I got back on. At the outset of logging in, the program says it pairs with the trainer. However, there is no resistance on grade increases. Please help because without the increase, the program is useless. Also, I use an iPad.


1 Like

Is there any hope for a resolution to the in-game sensor dropping issue? It’s really screwing up total TSS scores for structured workouts. My watch reads the power data simultaneously just fine, so it’s not the power meter source - it’s Zwift.

This is in addition to the still-persisting game initiation controllable and PM pairing issue thats been a problem for months now.

Is this thread dead or is anyone still listening?

1 Like

Here is my solution, and honestly it sucks but works. I unpaired the Wahoo from the trainer. I unpair my Garmin watch from the trainer. Reboot the Ipad. I can then get Zwift to pair with the Wahoo Kikr. Then I can repair my garmin with the trainer until the next ride.

I wish Zwift would tell us about this issue - I believe it is the new Bluetooth Low Energy pairing they are doing which is limiting the ability to pair with multiple devices. Instead of using forums, tell us through Eric S’s communication.

1 Like

I use a Kurt Kinetic smart trainer. I use an iPad for Zwift. After being off for about a month, about 10 days ago, I decided to get back on Zwift. It appeared that everything was properly paired, but when I rode the trainer would not increase its tension when the grade increased. I cannot get it to tighten the tension on the back wheel when the grade increases. Please help.

Same issues.

My setup is as below :
Trainer: Wahoo KICKR Smart Trainer (KICKR Version: 5) Firmware v4.2.1
Zwift: 1.16.1 (Aug 25)
Zwift Companion app
Apple TV 4K running latest version
Wahoo Tickr Heart Rate monitor
55 inch Sony LED TV

I am going to experiment with running Zwift on iPhone XS and using Apple TV to mirror screen on the Sony TV. hope that works

Apologies, I downloaded the latest ipad version on Saturday and if I connected power source to power pedals, cadence to tacx, control would then let me select tacx. I then went back to cadence and chose power pedals. I then selected BT hr monitor and I’m pleased to say everything worked like it used too! Whoop whoop!

Then this morning I did the same sequence with Apple TV but when I first enter the zwift app I also had to start the companion app on my Android phone so they paired before running the sequence above.

Once android paired and zwift was set up I then connected my Bluetooth headphones to listen to music on the android phone.

I hope this helps

Same issue here. Zwift sees Kickr as a controllable device, as well as a power source. Zwift sees Quarq PM as a power source, but not a cadence source. If I select the Quarq as the power source, then it shows up in the cadence menu as a selectable device. Quarq battery fresh, broadcasts fine to garmin head unit.

Zwift version 1.16.2
iPad Pro 5th gen, and 3rd gen. IOS 14.7.1
Quarq D4,
Kickr 2017