Can't Join RoboPacer [1.39.0][May 2023]

I get the frustration - I’m a pretty hardcore Zwifter myself with a paltry 55,000km to my name, so the issues you experience, I do just as much.

I can’t comment on our development cycle, but I will try to provide information where I can and flag issues that I see on here to our teams.

1 Like

I deleted the app and re-loaded. The issue still existed in Makuri with Coco but did not exist in TF version of COCO. This morning I was able to join but my legs didn’t move for the first 15 minutes.

1 Like

Just want to point out, I am also on apple Tv and have had issues locating robo pacer on certain routes. Today specifically Maria in Waptopia. I could connect to Maria in Makuri though. I also tried Miguel in Waptopia and that did not work either.

Also on Apple Tv. I could hook on with Maria in Makuri, but tried several times to locate Maria in Watopia with no luck this morning.

Thanks all,

This issue is now being addressed. It looks like this is more likely to happen if you remain on the RoboPacer side sheet for too long before selecting Start Ride, so quickly jumping into a pacer ride should increase the likelihood of joining the pacer without a problem.

1 Like

This is not correct. It occurs even if you join immediately.

1 Like

Still having this problem - and seeing many other complaints in-game from others - people having trouble joining - making wrong turns - or their avatar legs aren’t moving.

What Robo pacer is causing the issue?

Hi Gerrie - I have experienced the problem with COCO (in both Watopia and Makuri) and Maria.

We have raised it as a bug and our team have a fix in testing.


I had this occur one with coco group (joining using macOS Monterey and Zwift 1.39) but never since.

Frequently I have the no moving legs bug.

I’m not always with the bots, I alternate between them and riding alone on ADZ.

If it helps, I just had this happen with Bernie and Maria both, Volcano Flat and Tick Tock

Should be fixed on Wednesday.


Fantastic!! Thank you James.

Same problem past 2 weeks. Nearly impossible for Zwift to locate a bot when I select to ride w one. I’m only trying coco, but have ridden w Coco for years w no problems prior

I’m having same issue I register for pace partner and no one is there

Please see the post barely above yours.

Hey all - this bug is fixed in Zwift v 1.40, which began phased rollout today. Over the next couple of days, it will be available to everyone on all OS platforms. Please update at your earliest convenience.

I’m still having trouble joining a Robopacer (Coco) and I have 1.40. I run Zwift on Apple tv

Should be properly fixed in 1.41. We know some people are still having trouble.