Bushido seen , but not starting

I have a Tacx Bushido smart. It calibrates ok with the Tacx utility and is also up-to-date on the firmware. I have used it successfully with RGT and the Tacx web service, but when i try and use Zwift, it sees the Bushido if I use the companion app, but when i try and ride, the bike on the screen stays stationary and no measurements show even though I am pedalling. I am sure its something to do with the way I have set something up as it works fine with the other two training apps.
Any suggestion’s?

Hi @CLIVE_ECKETT, welcome to the forums.

Please list all the parts and pieces of your setup and how you connect. PC, Mac, iPhone, Apple TV, Android, etc… Are you using bluetooth or ant+? What information is showing on the pairing screen, do you see any watts registered there? The more info you can provide the better!

Hi
I am using an android phone Moto G6 ANDROID VER 9
Laptop running 64 bit Win 10 enterprise
I run Bluetooth to the Bushido using the ZWIFT companion. I also use Bluetooth when running the Tacx web service and the RGT service. All 3 services (including Zwift see the device). Zwift sees it as a Bushido and gives the serial number etc on the “controllable” screen of the laptop but it doesn’t seem to do anything when i then go and try to ride. I can see my avatar, but it just sits on the bike an does nothing.

Is it possible that those other apps is still paired to the trainer. Bluetooth can only connect to one ting at a time.

1 Like

Does your laptop not have bluetooth built in? Why are you using the companion app to bridge the signal?

no Gerry, I have tried them all separately and then powered off a;; devices and waited 5 minutes before rebooting everything to ensure there’s no prior pairing.

my laptop doesn’t have Bluetooth built in, so instead I use a Bluetooth dongle.

I’m guessing the issue is with the dongle, are you allowing Zwift to try to use bluetooth rather than using the companion app.

1 Like

If you use the bluetooth dongle you don’t need the companion app. Also make sure the trainer is not listed in the blutooth devices in windows.

1 Like

yes Mike, I’ve tried it both ways, i.e . just using the Bluetooth dongle on the laptop without the companion app. all that happens is that it keeps searching and doesn’t see anything. as soon as I use the companion app, it sees the bushido

Does the Bluetooth icon have a yellow triangle in the pairing screen.

Also, did you update the Bluetooth c++ package.

Windows 10 Bluetooth:
Redistributable Packages . Close Zwift, download and install this, reboot your machine and try again. https://www.techpowerup.com/download/visual-c-redistributable-runtime-package-all-in-one/

1 Like

not sure if it has a triangle next to it ( I dont think so, but I will check) I will also check to make sure I have the latest c++ update and will then update this chat. Thanks

1 Like

When you connect, make sure you have selected the Bushido in Power and Controllable.

If you are not opposed to it, get an Ant+ dongle and connect using that protocol.

Hi
Thanks for this suggestion. I have an ant+ tacx unit, but I thought that swift couldn’t use any+ to control the Bushido?

Why would you think that?? I have used Ant+ via laptops ever since the Kickr Snap came out. For me it is much more reliable than BT. I stopped using Rouvy AR/Fulgaz because, at the time, they require BT. I think AR still does.

Just connect via the FE-C option under Power & Controllable. The specs I saw online for a Bushido list that option. Unless you have a really old one with different specs.

Thanks, I will give it a go and update this chat later tomorrow. Thanks again.

All working. Many thanks to Chris and Gerrie. I updated c++ and then unplugged everything from my laptop except the BT dongle. It all works great. I really appreciate the help and advice

2 Likes

That is good news @CLIVE_ECKETT.

Ride on!