Brief loss of resistance after some turns in Watopia [September 2022] [SOLVED]

@shooj - is anyone looking in to this/ just so i can manage my own expectations.

It has been confirmed by a number of people on different set ups and a potential cause has been identified so looks like it is game related.

If you use Windows you can try this to test


what do I do with it? (basic terms i’m afraid!)

Replace the executable in C:\Program Files (x86)\Zwift (backup the original first to restore it later).

This is not a fix, the patch just disables the feature where I suspect the bug was introduced.


will give it a go and test it this evening.

thanks for your help on this, much appreciated

Yep, that fixed it. Didn’t notice anything else change while riding so hopefully could be a quick fix.

Thanks so much, watopia is back on my route selections :slightly_smiling_face:

Wow, nice one @oldnapalm - yet another community provided workaround.


So it’s confirmed the bug was introduced in game_1_28_ftms_road_grade_lookahead_time_exposed. I guess they could just disable that feature (server side, no client update required) until the bug is fixed, since it seems to be causing more harm than good.


do you know what it is meant to do?
I didn’t notice anything different in game so didn’t notice anything not happening as a result.

Given the feature name (road grade lookahead) I suppose its intention is to make the resistance change smoother by looking the road slope beforehand. It only applies to trainers which support FTMS, that explains why the bug doesn’t appear for ANT users or BLE trainers which use proprietary protocol.

This is excellent work, @oldnapalm, very well done!

Did a few laps of the beach island route this morning and that all went fine too. Previously a few of the turns here would have had the resistance issues.

Can you reupload the data? The bug still exists in the new update. They didn’t fix it

Odd, I tested yesterday after the update and it appeared to be fixed.

There’s an easy way to disable a feature on Windows, open ZwiftApp.exe with an hex editor (like HxD), search for the feature name (game_1_28_ftms_road_grade_lookahead_time_exposed) and change any character, then the actual feature won’t be enabled.

E.g. you can do the same with “game_1_20_home_screen” to have the old home back.

1 Like

Thank you. First impressions are good. I’ll test it tomorrow on more routes

I know a lot of people might be interested in this!

This is almost definitely beyond my ability but any idea why my text looks like this?

There’s an option in the “view” (or “show”) menu, visible columns, yours is selected only text and mine both hex and text. But shouldn’t be a problem, you just need to change a character (e.g. game_1_20_home_screengame_1_20!home_screen).

Thank you, you made my day. I have tested the watopia waistband route today. Before the tweak i had 5-6 drops at the same spots and now they are gone. Plus the Kickr+Climb Set up feels more smooth than before. I have no clue why they implemented a buggy feature like this without testing. I mean we pay for this service. The officials should offer you a 3 month free subscription for your work.


Hey all - wanted to let you know that our devs disabled the thing causing this issue on the server end. This solves it for all Zwifters regardless of OS platform, and also makes @oldnapalm’s Windows-specific hack unnecessary.

If you used the hack - you should revert it so it doesn’t cause problems for you in the future.