Bought a new Tacx, can't reach 450W


Up until August I alway trained with a Tacx Vortex and never had any problems with Zwift. A few weeks ago I bought a new Tacx Flux T2980. Earlier this week I wanted to do my first test ride with Zwift. What I first noticed is that the power is much more ‘jumpy’ than on my old Vortex when using ERG mode. A little deviation from my cadence and the power spikes are drop more than 50%. With my old Vortex the Tacx adapted a lot quicker in ERG mode. But this wasn’t the biggest problem.

In test ride I had to warm up for 5 minutes (150W to 300W, I think). After that I had to do 450W for 1 minutes. When I kept pedaling at the same cadence, the power was going up to about 350W and not any further. When I increased my cadence to 105-115 the power when to 430W or so, but after that it dropped again to 350W.

First I thought it might be because I use a new desktop PC. So, I tried again with my old laptop (which was working fine with the Vortex). But again I had the same problem. So my guess is that it’s not my PC that is not working okay.

I even tried with my laptop 10 centimers from the Tacx to make sure there are now connectivety issues. I use ANT+, but I also bought a Bluetooth dongle to test with bluetooth on my desktop pc. It didn’t help.

Oh, and calibrated the Tacx with the Tacx app. And checked for updates, but I had the latest version.

Do you guys know of any bugs that cause this problem described above? It’s very frustrating that the new upgraded Tacx doesn’t work. I was hoping for Plug&Play. I invested a lot of money for better equipment and some more comfort, but this is increasing my stress levels :wink:

If anyone has any tips to get rid of my problem, I would love to hear them.


Hi @Auke_Meinsma_Fytse_b, welcome to the forums.

Have a read of this article:

Hello Mike, thanks for your response. I didn’t read the article, but I did now. I could not find anything that looks like my problem. I can’t find why my Tacx drops down to 350W everytime I have to cycle, for example, 30s at 450W.

GPLama’s review notes that this trainer performs better when connected by Bluetooth with both SIM and ERG. Going bluetooth will improve response times. Yet this one still has problems holding power targets above 300 Watts.

One other thing to try is different gear combinations. You’re doing some big watts there so maybe a harder gear might bring better results.

Alright, so I should be shifting gears when in ERG mode when the power is changing? I tried this and the power still goes back to 350W. And it’s very exhausting, because when I shift gear the first second or so are very very heavy.

I tried with Bluetooth and thing didn’t change.

So this is what happens. I have put everything on bluetooth now. It should be 60s of 150W, 60s of 450W and 60s of 150W. I tried shifting gears in the middle part, but it didnt help.

And this is what is happening with the Tacx app. So, same problem:

The latest Tacx firmware is 3.3.40/1.1.6, but I have 3.3.45/1.1.6. Does that make any difference?

Ah, I think it’s just a display error in the Tacx app.

Can you test ERG mode using the tacx app or other software? Maybe this is an issue with the trainer and not Zwift?

1 Like

Ideally you should not shift in ERG mode, but put the trainer in the middle of the cassette and on the small ring at the front. Yet depending on you gears (especially those modern gravel gearings) this might result in a flywheel speed that is too low for 400+ Watt targets. 34/24 gear might not be possible for some trainers, 39/15 gear should be stable enough.

Let’s rule this out, and if you can test ERG mode with other trainer apps and it continues to behave like this, I would suggest to exchange the unit if you can.

I have given up on new options. I will wait for an update.

Update: I am getting a new Tacx from the supplier

The new Tacx is working fine. Thanks for all the replies.

I am off, cycling :wink:

1 Like