Black masking in some objects

I have updated Zwift version to the latest and it seems some objects in the world are not working, instead black masking is shown on them. Also I get some flickering black squares around other players when attending events. My setup:

Macbook Pro M1 laptop

Hi @Artur_Gajewski

Welcome to the Forums!

This is the first I’ve heard of this issue. Do you have any screenshots as an example?

What screen mode settings do you have set for Zwift – Full Screen or Windowed view? Have you tried swapping between either of the two settings and does the graphical issue happen regardless of which view you have set?

What about your Game Resolution settings? Have you tried lowering that at all?

Usually means corrupted assets and/or cache. Do a clean reinstall of the game and it should be fine.


Here’s an example of what it looks like.

Yes, in addition to deleting the app itself, I also removed the files from Library/Application Support folder and re-install did the trick. Thank you for your help!

1 Like