Bkool smart pro 1

Please also send me the windows version. Can’t get started :frowning:

1 Like

@Sandy_Thomson i would love to get the Windows files. We Hope you still would share

Have anyone succeeded with the old BKool software lately ? I have received the file from Sandy, much appreciated, but after installing and making sure it doesn’t update the installation, it keeps saying “error connecting to multiplayer server”, and won’t let me get to the menu screen. Have anyone found a way to bypass this ?

i have tried with a newer version 4 but this version dont have the button we need, and that said the same, but you can go offline and then come in to the program.
Can you please send the files to me then ? :smiley:

I tried to go offline, but it does the same. I don’t get any further in program.

I can try and link to the file to you, and then please come back if you manage to get it working :slight_smile:

I have a link to the software, but I have no idea how to send you a PM, and I am not allowed to post a link.


I have the same issue as you…
it looks like you cant connect to the bkool indoor offline in that version and the connection to Bkool through 3.53 seams closed… Anyone who can find another way with that version please :pray:

@Sandy_Thomson Can you figure this out to get trought the login screen :slight_smile:

I have found a solution but I cant share links here.
Search Google for ZycleDFU and take the first link to an Italien site then expand the first comment and there is a guide with a link super easy :grin: write again here if you cant find it :grin:

Thanks, I managed to get it updated to 3.25 with no error messages. But Zwift still doesn’t recognise the “controllable” part. Did you in any way activate the ANT+ FEC communication afterwards, or did it work immediately after the firmware update ?

And did you run any other things than the reflash.bat file ?

Sorry, I don’t own a Bkool any more and haven’t had a chance to try and install the old software. I can’t find the ZycleDFU link either - I probably get different results to you…

No i did not run anything else.
And yes mine worked right after but you cant use it with bluetooth, you need to use an ANT+ usb dongle in the PC for it to work ?

I did have my ANT+ USB dongle in my pc at the time. I have to check if the dongle is broken or not recognized by my PC. Thanks for the help.

I did not have the right USB driver for My dongle so make sure to install the right one :grin:
And in swift if the ant+ dongle works the ant logo in the corner is blinking like it is serching. Alsp try to deactivate Bluetooth on the computer so it dont connect through that😁

Ah ok, I thought it was supposed to connect to the other things through bluetooth, and only the “controllable” through ant+. I must try this when I get home. Thanks again for elaborating.

It worked when I turned off my bluetooth :slight_smile: Thanks alot.

Hi @Kim_Pedersen1 & @michael_hansen3 can you help a fellow dane out?

I’ve gone through the process with getting hold of the ZycleDFU but firtstly I’m getting 3.33 - not 3.25.
How are you guys getting the 3.25?

What part of the process is it that I’m effing up?
I’ve run the .bat as described and it goes through the program as (looks like) intended; but can’t get the bike connected either way.

  • The ANT works as it pick up my HRM.

Thanks in advance!


I didn’t study the dos-prompt while operating, so all I saw was that it was a success the second time I ran it. So if you get a higher version, maybe I did too ? Don’t know how to check now.

Did you turn of the Bluetooth on your PC ? That did the trick for me.