Bkool power levels way off again


(Simon Whittaker) #1

Hi, for the last couple of weeks the power levels are not correct when using the Bkool pro trainer. my FTP is around 230 watts, although i cannot run a test as the power results are incorrect. Last night Zwift was reporting 350 to 400 watts for extended periods of time when it really felt closer to 250 max. My heart rate suggested around threshold levels not Z5 / Z6

I also had the problems earlier in the year as well but a firmware update from Bkool resolved that. this is feeling very similar to that again. Is anyone else experiencing the same?

 

Thanks

 

Simon


(Johan Piculell Sz (B)) #2

I have the exact same experience. Filed a ticket on this a few days back, waiting for an update.


(Arturo G. Artur) #3

The same for me on Bkool Classic with 2.04 firmware. I can go to 330watts for a long time and i can’t do that on real life. 

Today I did a race with a power meter and results on zwiftpower were the worst in time, so I guess that it matters on how Zwift calculates the virtual speed.

 


(Peter Mott) #4

Hi, did anyone get an answer to this one? I have exactly this problem where power readings gradually creep up to over 350 watts when realistically i’m probably only around 200- 220 watts. After a while the Bkool Smart trainer then appears to apply the correct resistance again and power readings are back to what i would expect.


(Simon Whittaker) #5

Hi Peter.
The problem is with Bkool. It is the same on both Zwift and Sufferfest although seems slight worse on Zwift. It makes FTP testing impossible. But if you guess a figure and ride intervals you dont really notice it. I sold my Bkool and would not buy / recommend to anyone.


(Peter Mott) #6

Thanks for the quick reply Simon. The Bkool/Zwift combo has worked well for the last year, up until a session last Tuesday, and then again tonight. I’ve had 3 in between which were fine.  I’ll see what i can get out of Bkool support… but not holding out too much hope.


(Johan Piculell Sz (B)) #7

I also sold by Bkool and now running on a Neo.

Bkool support was not much of help, if I recall correctly they wanted logs from my bkool sim during the issue, even though I clearly stated I was using Zwift.


(Mattias Dufva) #8

I also have the same problem. My issue is if i have to change back from ANT+FE-C to the original configuration for updating the fimeware? And how can i do that?


(Peter Mott) #9

Hi All,

A quick update on this. As per all the guidance I had been reading in the run up to buying my trainer, I was using a 5m USB extension to place the ANT+ dongle right beside the Bkool trainer. I’ve recently decided to remove the cable and insert the ANT+ dongle directly into the laptop. So far, I’ve probably done around 6 activities like this and power levels have been as expected.

On a similar note, which got me quite curious, I was having difficulty a while back trying to get the trainer to do a firmware upgrade. I always got an error during the process. One time, I decide to remove the USB cable and place the ANT+ dongle directly into the laptop, then place the laptop next to the trainer. The firmware upgrade worked first time.

So, in summary, I’m hoping the 5m USB has been the problem… But I’m going to give it some more time before I decide if I have a resolution.

I’d be interested to know if anyone else was using a USB extension?

I’ll update this thread again after I’ve completeed some more rides on Zwift.

Peter