Battling Heart Monitors, only one winner!

My wife and I ride together each morning on dumb trainers.  We both use BLE speed and cadence sensors.  I use the mobile app connected to a Windows 10 laptop and she uses direct BLE connection to a Mac Mini.  I have a heart monitor, also BLE to the mobile app.

Recently, she bought a VivoActive HR watch and it broadcasts HR to Zwift via an ANT+ dongle on the Mac.  If she’s alone, it’s fine.  But if I start my HR monitor, her’s does not work.  

To begin, I get everything of mine set up and start riding.  She opens her pairing screen and selects the VivoActive HR.  It sees my HR monitor via ANT+ as well as her VivoActive.  She selects her’s but it shows 255 bpm on the screen and never changes as long as my HR monitor is on.  When I take mine off, as soon as it stops broadcasting, her HR monitor begins to work correctly.

Is there anything I can do, change, break, etc. so we can both use our HR monitors?

I’ve never heard of anything like this, but it sounds like an interference issue. Zwift just reads from your sensors, so if it can’t pick up the signal, you’re going to see issues. See our recommendations for troubleshooting signal drops.

Well, I’d very much agree on the interference thing… However, it doesn’t seem to be it can’t see the signal, rather sees too many.  The pairing menu sees everything!  We select the VivoActive HR but it sticks on 255 bpm until I take off my HR monitor (which is paired to me via BLE and mobile app).  Then her’s works fine.  I plug mine back in and hers turns to crap again (technical term).   So, essentially, my HR monitor, which does both BLE and ANT+, overpowers everything she’s selected.  If she selects my HR in ANT+ mode, she sees my heartrate in her screen.  

So… if both HR monitors are on and she selects VivoHR, she gets a static 255 (max 8 bit number).  If she selects my HR monitor it displays my HR on both our screens.  Mine from BLE (cause I don’t have any ANT+) and my HR on her screen from ANT+.

Is there a way to turn your HR monitor’s ANT+ off?

 

It just sound that your HR monitor saturate the room with data.

I have a discontinued GNC HR strap and no way (that I know of) to talk to it to disable ANT+.  

However, I did find if I get my wife started before me, the VivoActive transmits fine to her Zwift screen.  Then I start Zwift on my laptop and we’re both working normally. Unfortunately, I usually start about 15-20 minutes before her, so it makes it a bit of a problem.  I have to go get her watch, wear it, pair her all up, and then get myself set up and riding… leaving her on the “Ride with” screen so she can find me in the rider list.  

Although we’re both following each other, I’m not at the top of her list, she has to scroll to find me.  But that’s another post.