Astoria Line 8 Route - Badge not awarded


I tried to complete a few Routes today to earn myself a badge. The New Your Route Astoria Line 8 does not work. See image of Zwift’s Route below:

Below is my ride. I gave up after 23.3km.

This is getting to be a real problem. There were so many issues the the London Surrey Hills route, that I am not prepared to ride a larger Route, for example Mega Pretzel, just in case there is a bug with the awarding of a completion badge.

Come on Zwift…What is going on?


I tried the Astoria Line 8 route for the 3rd time today with the ‘u-turn’ method at the start, WITHOUT success.

This route is stuffed if one wants an achievement badge.

I’ve noticed something really interesting.

Even though the Astoria Line 8 and Knickerbocker route splash screens failed to appear once I completed the routes, I have claimed the achievement badges!

So check your achievement section on Zwift… you might have claimed your cherished prize.

Really strange.

I drove the Astoria Line 8 route in New York today but didn’t receive a badge, then drove once more and after the 2nd time still no badge. Can this be fixed, please?

I got it without any issue a few weeks ago…

I did Knickerbocker this morning and it also worked fine, then I tried the u-turn trick as soon as I got the “route completed” message on the screen and immediately got the Knickerbocker reverse route achievement. 2 for one!

I also have to drive Knickerbocker, thanks for the tip.

Astoria Line Route & High Line still will not open for me and it’s Easter now … :man_shrugging:t3:… Just keep trying I guess… :+1:

I completed Astoria 8, yesterday, and haven’t been awarded a badge. This is the third course I did not get a badge for and it is getting old now. Zwift don’t seem to be doing anything about it.

just completed this route for the first time today. no on-screen badge, or points awarded, but i did get the badge in my collection.

seems like zwift still has a lot to work on.