Assioma Duo connection to Zwift with only one pedal's power showing

First time Zwift user so this might be operator error, but… My bike with Assioma Duo pedals paired to both pedals in Zwift, but only showed power for one when I was riding. Passed by everyone as I was basically Zwifting with one leg. Tried my other bike with Shimano power meter cranks and Zwift worked perfectly. How do I get Zwift to read both Assioma pedals power? Any suggestions would be appreciated.

Zwift only pair to the left pedal because the right pedal sends the power to the left then the left combines it and broadcast it.

Use the default settings on the pedals.

Thanks very much for the help. Worked right away.

1 Like

How do I use the default settings on pedals? I’m having the same problem

Just make sure you did not convert it Uno

In the pairing screen you will only see one pedal.

1 Like

It isn’t just that.

If you go into the compatibility with other apps section you need to make sure that is also set to send power for both through the left pedal.

2 Likes