Apple Watch refuses to send data

(I tried to attach screenshots, upload them elsewhere etc but I am not allowed to post images or links so it’s difficult to illustrate the issue).

Due to long term illness and major surgery, I have struggled to get back into training. I am now trying for the 4th time this year.

Each time I have been unable to get HR data from Apple Watch to show in Zwift.

I run Zwift on my iPad Pro 11 and the Companion app on my iPhone XS. I have the Apple Watch 4th generation with LTE.

I have no problems with my watch in any other situation.

What happens is that the Zwift app sometimes finds the watch, sometimes not. Sometimes it pairs, sometimes not.

Regardless I get 0 HR data.

Today Zwift found the watch after a few reboots, but even when it paired it said «NO SIGNAL» or just showed 0 pulse. The watch itself says «Unpaired».

I use the HRM on my watch daily for health purposes, and have never had issues with it.

I have read all guides I can find but nothing seems to help. I have no idea how to proceed.

I really would like to avoid having to buy a separate HRM strap when I have a $500 gadget which is supposed to do the job. :slight_smile:

My trainer is the Tacx Neo.

If you search the forum, the Apple Watch is pretty unreliable. You can try to follow the steps as Zwift outlined in its guide, the one that says that Apple Watch support is still in beta. That may or may not work consistently for you. It has not for me.

Personally, I’ve given up on the Apple Watch. It is designed to measure and report heart rate within Apple’s own walled garden. I am assuming that it is not designed to do things like pair to a bike head unit or an external app. That doesn’t mean that it can’t do that, just that it’s not going to be reliable. Or maybe Zwift haven’t put in the time to make it work, I don’t know. All I do know is that I have given up on mine.

You might want to try searching for an app called Heartcast. It was written by a Peloton user to get their Apple Watch to broadcast HR to the Peloton via Bluetooth. It’s free. It may work, or it may not. One person i know said it seemed to work on Zwift, but not on the road when broadcasting to a Garmin bike computer.

1 Like

I have an almost identical hardware setup and although it takes a few cycles through various tries to get the connection, I can almost always get it to work. One tip is to make sure you remove the Zwift app from the watch and use the companion app there instead. A key for me seems to be to start riding (ie hit “ride”, but before your event has started), then go back and attempt to pair.

My hardware:
IPad Pro 2018 11 inch, iOS 13.7 (yes, not current, but I’m lucky because this is avoiding the crashing bug introduced in 60239 release and not fixed in 60474)
IPhone XS iOS 14.1
Neo 2T
Watch series 4 (make sure Zwift app not loaded on it)

Here’s what I currently do:

  1. Start the ride 15 mins before event begins (it does seem to make a difference to do the steps below after hitting the orange RIDE button)

  2. Try to connect a Bluetooth device from within the Zwift app on the iPad, looking for your watch on the list (rarely works first time through).

  3. Quit and restart the Zwift Companion app on your watch (look up how to do that, not something I ever have to do for any other app on my watch, and I wonder if this app is the ultimate source of the flakiness), then repeat step 2.

  4. Quit and restart the companion app on the phone, then repeat step 2.

  5. Try steps 3 and 4 again, but in the other order.

Just to be clear, I’m not saying you’ll have to do all of these, you might fix the issue at any of the steps and therefore not need to run through the other steps.

Hope this helps, I’m confident you can get it to work consistently. I don’t know where the unreliability in establishing a connection at the beginning comes from, but once it’s going and I’m actively riding, I don’t think I’ve ever lost the connection during the ride.

1 Like

Thank you Justin, I reinstalled the Zwift apps on my phone, and installed only the companion on my watch. It did work after a few tries!!!

However, it never stopped…so ten minutes after my workout I realized that the watch was still running the companion app and showing my «in game» heart rate. And there was no way to stop it apart from restarting the watch.

I might listen to @Weiwen_ng and accept that the Apple Watch is not perfect for this. I think I’ll just get a BT HR strap instead.

@tormodg I frequently had this error. On your iPad, you should eventually get a notification that some devices are still connected to Zwift. Long press the notification, and choose the disconnect option. Do not short press it, because that will simply pull the Zwift app back up without any option to disconnect.

Another thing you can try is force close the Companion app on your watch. Short press the lower rectangular button (I.e. not the dial). Scroll to the Companion app, then slide it left. It will reveal a red X. The problem is that this does not always close the Companion app. In general, that’s how you force close an app on the watch, though.

1 Like

The zombie watch app problem had gone away recently, but returned on my ride yesterday. Just quit the watch app (not full watch restart, just the app), or the companion app on your phone. Not a big deal. Like you I was getting close to shelling out for an external HR monitor, but If you’re stubborn like me you want the Watch to do what it’s built for…

I did re-edit my post above with the updated routine I go through now.

1 Like

Thanks @Justin_Thackeray. Your suggestions worked fine, I had 4 workouts without issues. Then the watch refused to pair and when it finally did, I had dropouts every few seconds for the entire workout. Then it worked again for the next workout, but yesterday I had to do all the magic routines to make it pair again. No dropouts though.

It «works» but if I have to spend a few minutes before every other workout I will probably just get a HRM strap. It’s so incredibly annoying.

1 Like

My last ride a few days ago I had the hardest time in a long time getting the pairing to stick - took me almost 15 minutes. They’ve been trying to solve Zwift app crashing on start-up for iOS users (which seemed clearly to be related to Bluetooth) thru multiple recent app updates so I have a feeling that one of the code tweaks they did in these patches has affected Apple Watch pairing negatively. Like you say, it’s frustrating that it kinda works, but requires so much messing around to get it going.

Against my better judgement, I’ve been trying to get the Apple Watch to work on my non-critical rides. In my case, Zwift usually finds my Apple Watch at the pairing screen. I’ve said this elsewhere, I think, but I believe you need the Companion app running and open on your phone to successfully pair the watch. Anyway, at the pairing screen, I usually check the Companion app on the Watch and wait for it to say “pairing” or “in-game” and display a heart beat. This usually happens. Contrary to @Justin_Thackeray, I usually find my watch on the pairing screen.

From there, I think that about a third of the time, I accept and move on to the home page, but the Watch doesn’t display a heartbeat. I’ll re-pair the devices if I notice this.

Unfortunately, even after that, the Watch will sometimes fail to transmit a heart beat during the ride. I think this probably happens a quarter to a third of the time as well. And naturally, you have to stop your avatar to re-pair the device, which is not acceptable in a group ride or with a Pace Partner. Anyway, that’s where my own issues are right now.

It works just frequently enough to convince me that it can work, but really, I should accept that it’s futile at this point.

Pretty sure I never said that… I never have much of an issue selecting it, or seeing the initial stages of pairing happening, but the problem I usually find is that by the time I have joined a ride/race its no longer showing an HR in the Zwift app. Then I have to start the whole rigamarole again of beginning pairing. Often times you can initially select it, and then shortly after you’ll see “no signal”.

Hi @tormodg

I was facing a similar issue to yours.

After a lot of struggling with it I think I see whats happening:

As I use my device to run and ride. I will switch between using the app on an Ipad for running with Stryd and a treadmill and an Apple TV for cycling. Whats happening is that the bluetooth signal is being held by that device unless it is restarted completely.

Zwift have to figure out a better way of a device completely disconnecting from the watch when its not being used.

In short solution is restart all devices using Zwift and bluetooth connections before pairing again. I hope this helps.

On a side note the Apple Series 6 works far better then a 4 on transmitting a constant HR to the IOS app directly. On the 4 I had to keep the wrist strap really tight for it to somewhat work.

1 Like