Apple TV Zwift App crashing on startup

network-error

(Blake Hoppe) #1

After opening app, the screen freezes, turns white, and goes to Apple TV home screen after hitting the login button. I have updated the Apple TV and Zwift to the latest software, deleted and reinstalled Zwift, performed a “force quit” on the app, and also tried restarting/unplugging the Apple TV. Anyone else experiencing this? Everything was running smoothly until the app crashed mid-ride last night and I haven’t been able to get it restarted since. Thanks in advance!

Blake


(Lin Alan) #2

I noticed this a couple of times as well. Zwift starts, goes to a white screen, and then immediately returns to the Apple TV home screen. It definitely crashed because it’s not there to switch to or force quit. I launch Zwift a second time and it works.

As I said, I have seen this a few times, but not every time. Also, I only had to relaunch Zwift to get it working.


(Aaron Zwanzig) #3

Relaunching usually gets it to go for me when this happens. There have been times when I had to try several times.


(Blake Hoppe) #4

I’ve probably tried the steps listed above 20 times now. Even did a full reboot from factory settings on the Apple TV. No luck yet, and no reply from Zwift support on a possible cause yet. Hoping to hear back soon!


(Lin Alan) #5

Maybe try the following: delete the Zwift app, remove power for several minutes, power it back up, download fresh Zwift app. :man_shrugging:


(Vince Cammarata) #6

Yeah, happened to me yesterday also. Ended up rebooting AppleTV twice without success. Then rebooted iPhone and everything worked fine. Today everything is fine. Think it might be the connection between Zwift on AppleTV and Zwift Companion on iPhone.


(Lin Alan) #7

Could be coincidental, but it’s an interesting possibility. We’ll have to wait for @Blake_Hoppe to give it a try and report back.


(Robert John Holash) #8

This started Happening to me too! Restarted Zwift, restarted Apple TV, deleted Zwift - reinstalled Zwift still happens white screen … login screen instant crash. I have to use Zwift on my iPad right now! Frustrated.


(lolander) #9

Just started happening today on the latest Apple TV 4K, had to restart zwift 4-5 times before it would take me to the log-in screen and not crash.