Apple TV Issues with Kickr core possibly after Zwift update?

All of a sudden Zwift has stopped recognising my Wahoo Kickr Core Trainer. Same set up used for 18 months - no issues, Apple TV, Wahoo Kickr Core. Companion app has been dropping out recently but that was just annoying. Trainer is fine and bluetooth connects to other devices on it, Apple TV bluetooth appears to work with Iphone. Seems to have just stopped working after latest ZWIFT update?
I reset Apple TV, reinstalled Zwift and Trainer worked once then didn’t recognise trainer, repeated then same result so my guess is a software issue with Zwift?
No point in having Zwift if the trainer doesn’t connect - anyone else have the same issue?

Do you force quit the Zwift app after each session? That should resolve a lot of problems (eg no sound after re entering the game).

Thanks for your reply. Not sure how you force quit the app on Apple TV. I do what I’ve always done and after saving game and going back to ‘home screen’ press menu and then shut down Apple TV box. I did a factory reset of Apple TV it sees the Trainer once then doesn’t see it. My thoughts are it’s either the software since update or some issue with the Bluetooth signal/connection on Apple TV. I think it can only connect 3 devices one of which is the remote. The apple TV seems to work with okay so wondering if anyone else had problems with Apple TV and Wahoo KIckr Core. Trainer works fine with Iphone and Wahoo app.

Double click on the home screen button, then select and swipe up the Zwift app.

Hi Jurgen, Thanks but the problem is with Apple TV device itself not an Iphone/Ipad. I think the advice above is for Iphone/Ipad. Apple TV works differently. Zwift works on Iphone.It was just to see if anyone else using Apple TV is having problems.

If you double-click on the TV button on the Apple TV remote, you can force-close.

Andy, the button is officially called „TV / Home“, see https://www.apple.com/uk/apple-tv-4k/specs/. :roll_eyes:

Hi Jurgen/Steve - Thanks, misunderstood, yes worked out how to do it. Sorry.
I seem to have resolved this by deleting the Companion App which seemed to be causing an issue. Reinstalled companion app and so far it’s working.
Thanks for your help and advice
Andy

1 Like