Android Zwift Companion Bluetooth Bridge how to

Continuing the discussion from Zwift Companion v3.9.2 Dec 16, 2019:

Just installed zwift companion 3.10.0 denice selection to setup bluetooth bridge does not seem to exist, not on connection page, can anyone help?


Hi @Harper_Peck welcome to the Zwift Forum! I noticed on our server logs that you’re an Android user.

The Android version of the app lacks the “Select Device” part of Settings because the ZC app will automatically create that bridge. PROVIDED THAT you allow the app permissions to your Locations settings.

In Android OS, Bluetooth permissions for an app are unintuitively tied to Locations permissions. :man_shrugging:

You can fix this by going into your devices Settings > General > Apps & Notifications > App permissions > Your Location > Companion.

Alternately - you can uninstall ZC then reinstall, and allow Location permission.

1 Like

Thanks so much, my selections were a little different but pointed me in the direction, then had to switch from bluetooth to companion in zwift, hooked right up and worked!


Thanks for looping back to let us know this resolved your problem!


I cant get this to work at all. It has done so before but now it won’t find the turbo to pair with. Works fine for my son with his Apple though so obviously a setting.

Location is enabled in companion
Zwift and Zwift companion up to date
Phone up to date
Im using windows 10 and android on a Samsung J6.
PC and phone are on the same wireless neteork/channel
I’m logged into the same account on Zwift and Zwift companion.
Tried different USB cables.

I just feel that something is clashing somewhere. When I try and connect in told that Garmin connect may clash so I disable it. Makes no difference.

Im told to wake bluetooth devices up but it doesn’t help.

Tried another android device and it works albeit it lost signal twice. What is the problem with the phone though?

Is your companion app showing the map of the world? Or is it on the home screen? If it’s not in the map check the drop down menu for a “game” option, that needs to be available for the bridge to work.

Also are there any other bluetooth devices that could be taking the signal/bluetooth interference? That could be an issue too.

1 Like

It automatically goes to the map screen when Zwift opens and tries to pair but doesn’t find the device. I select connect using Zwift companion.

I dont even have bluetooth going elsewhere as I gennerally switch things off when not in use .

1 Like

Hi @Mark_Graham1
If you’re seeing no sensors whatsoever on the Windows laptop, I’m suspecting an issue with the laptop’s Bluetooth hardware / drivers.

What make / model laptop is that Windows 10 machine? Is the Bluetooth radio enabled? Are you using the latest drivers from the laptop manufacturer?

Curious - USB cables for what?

As stated it all works when my son uses it with his I phone so the computer is working ok.

usb Cable to connect the phone to the computer

It’s a Lenovo desktop. I have no idea if its radio enabled. The desktop is not bluetooth so im using my phones bluetooth (android) connecting to the PC with a USB cable and using ZC to try and get the connection.

For the Zwift Companion app on your phone to “see” the Zwift game app on your laptop, both the phone and the laptop need to be connected to the same WiFi network. Please verify that?

The USB cable is for keeping the phone powered? For simplicity, it would be better to plug in to a USB wall charger block.

Both on the same wi fi frequency. The USB cable is to connect the phone to the PC which is not bluetooth.

I’ve just tried another android device. Got it connected for about 5mins until it list signal. Could not reconnect or even detect the turbo after that. I give up. ZC is useless


This option is available by clicking the gear icon on the upper right hand side of the screeen in the Windows app.

(I was having a lot of trouble using Windows with Zwift, too)

Hi everyone,

I just would like to update the feed with that information:

In my case, I did everything correctly except that my Tacx Neo2 was already connected via BT to the Tacx utility app on my phone. Therefore, other apps did not find the Taxc Neo2. I simply closed that app (in Android, the “3-vertical-stripes” on the bottom left on your phone and "close all2 or swipe upwards on a given app) and then Zwift found it directly.


1 Like

I didn’t mean to flag this. I pushed wrong button and made it worse trying to undo it.

I had tried everything, USB extension, etc. still intermittent with ANT…then saw that trainer was paired to bluetooth on computer (passively), once I disconnected this completely, setup stabile

Bonsoir, j’ai téléchargé Swift sur ma tablette Xiaomi qui est Android, puis zwift compagnon sur mon téléphone portable aussi Xiaomi Android.
Le couplage ne s’effectue pas et je souhaite donc passé la connexion via le companion, MAIS je n’ai pas l’icone en haut à droite en forme d’écrou qui permet de basculer cette connexion
Merci de votre aide

Hi, I just want to share my experience with Companion connection problems. I done everything, what’s enlisted in your guide (same WiFi, permissions, etc), but still got no connection between Zwift and companion. Then I realized, that on my phone there’s a VPN apllication runs permanent in a background. Of course closing VPN app caused Companion connection turns on in the blink of an eye.
I hope my example helps other users with connection isuues.
Best regards and ride on,