Android phone not linking with devices

Took a week off of training and when I got back to on 2/5 I could not get my Android phone to find my trainer, cadence or heart sensor. Fiddled with it for a half an hour then borrowed my wife’s iPhone and linked up with no problem. Tried the Android phone tonight (2/7) and still could not get it to connect.

Wondering if it has something to do with a recent Windows 10 update.

Want to confirm your setup. You’re using the windows 10 machine to run the game app, and the Android phone to run Zwift Compaion, and using ZC as a Bluetooth bridge, correct?

Or are you running the game app on the Android phone?

Anyone else having issues with the andoid app.

been using it on my pixel 3 and cast to TV. this setup had been working well tell last few days. now im unable to connect my elite zumo. just searches but doesnt find the trainer.

So far i have unistalled the app. reset cache and permissions. still same result doesnt find trainer.

Also tried my wifes samsung A8 with same result.

Can comfirm works on my ipad and pc via bluetooth so not the trainer at fault.

any ideas?


Setup is exactly as you stated…Win 10 running game app and Android phone running Zwift Companion - been using this setup without incident for 3 years.

1 Like

Hi @Garry_Muir
I merged your question into this thread because both of you have the Pixel 3 in common. Please confirm that you were both prompted to install the latest Android update before this trouble began?

I’ve asked our QA team to investigate and hope to have an update for you soon.

@Shawn_Hemingway_D and @Garry_Muir

For Android apps to access the Bluetooth radio, you must enable permissions for that app to access the Locations folder.

With the latest versions of Android (which I’m assuming both of you are running on the Pixel3?) Android buried it two layers deep. See this thread from our Android dev.

Thanks for merging the thread.

I’m still having no luck pairing with my pixel3 and also on my wife’s Samsung A8 2018.

I have enabled permission for location services for the app. I got the prompt to enable this on installation.
Further this can be seen in the zwift app permission settings.

Is there something else in missing.

I also reset cache and cleared data on the Bluetooth system app with no joy either.


So after an afternoon of faffing about and getting nowhere. I have factory reset my phone.

Result. Still can’t pair with my zumo. Does not find it in the pairing menu.

Loosing the will to live with this.

Definitely something broke with the Feb app update.

As I’ve said. On my pixel 3 I can see the zumo in elite app. Rouvy and the bkool app. All work fine. So it’s only the ZWIFT app that I’m having issues with.

I can get my zumo to connect to ZWIFT no probs via my laptop and also on my iPad. Just the Android app that is not working.

Driving me nuts.

Finally got it to pair with my Zumo.

Had to select cadence sensor first then it connect to my zumo. Then selected speed sensor and it found my zumo. Once I selected both of these it then automatically paired with the controlable.

Glad to have it back up and running on my phone. I can now chromecast it to my TV.


does your zumo work on android via Bluetooth? do you get resistance in sim mode?

mine works ok for erg mode workouts but no resistance at all in sim mode

Yes all working in resistance mode too.

that’s interesting - a few others on here have complained of no resistance in sim mode when using the android version

Hi Chris I take it back. You are correct I’m getting no resistance with android app.

My initial testing was on a flat route so did not notice the lack of resistance. Upon trying a hillier route can confirm it doesn’t work with the Android app.

hopefully zwift will be able to sort it - i’m lucky and have more than one trainer and am able to use windows as well as android so it isn’t a huge problem for me but i’d like to be able to use my android tablet with the zumo

Yeh same here. Luckily I have an iPad and a laptop.

Android is the easiest for me though. Can cast my pixel 3 to my chromecast. Of course can do this with the iPad. If only I could wrestle it off my son.