After crash recovery no upload to Garmin Connect

Running Zwift from iPhone for the first time in a few days. Zwift said update the app, so I did. I then started a 1-hour TrainingPeaks workout. After about 8 minutes, Zwift disappeared. When I restarted, Zwift asked if I wanted to resume my activity. I said yes. The clock kept running (from the 8-minute mark), but the workout started from beginning. I did the workout and exited normally. Zwift companion shows two activities: the 8-minute first activity and a 1 hour and 8-minute workout. But Garmin Connect (and Strava and TrainingPeaks) show only the first activity.

It’s a common issue. Zwift doesn’t handle crash recovery very well in terms of your activity files.

On Windows you can access the files up manually upload them but not in your case.

I believe this is being looked at.

I think this process might still work… haven’t tried it recently

When I sign on Zwift using my computer, I see both pre-crash part of my ride, and the full ride. But when I downloaded the .fit file for the full ride, Garmin says the ride was already downloaded (and shows that what I downloaded was the pre-crash portion of the ride). I checked and saw that both rides have the same file name. But even after I changed the file name for the post-crash ride, Garmin recognizes it as the short, pre-crash ride. Oh well.

That sounds fairly normal for crash recovery files.

I don’t use Garmin Connect, but had once similar problem with Strava. Can’t you delete the activity in GC and try to download the correct fit file?

Thanks for the suggestion. I may try, but the problem seems to be with the .fit file I can download from Zwift—Zwift appears to have the same .fit file for the pre-crash and post-crash portions of my ride (even though Zwift shows different totals for each ride, so the correct data must reside somewhere). (I tried renaming the second file and then uploading it to Garmin, but Garmin was smart enough to realize the underlying data were the same.)

OK, so, I say this with the caveat: use this tool with extreme caution.


You may be able to merge files, or change the “source device” tag for a file such that Garmin will accept it.

Thanks for the suggestion. Unfortunately, the .fit file on Zwift seems to be the problem—it doesn’t seem to have the complete ride, only the pre-crash data.

That’s pretty normal for crash recovered files. Because of recent crash related issues it’s a subject that’s popped up a fair bit of late. Almost always one of the files is missing data.

Like i say i think they’re working on it.

Got it. I was just trying to be friendly by responding to folks who offered suggestions.

1 Like