Add ability to change smart trainer resistance during FTP test.


(Jim Fowler) #1

When doing the FTP test, as soon as you enter the 20 minute test period the resistance is far too low while using a Wahoo Kickr to get any decent wattage.  Even in the top gear peddling as fast as I can I am lucky to get 110 watts.  Add the ability to change the trainer resistance to compensate for this.  I have found numerous posts with the same issue.  Some have found they can connect to the trainer with the Wahoo app and turn up the resistance, but this is a hack and should be native in Zwift.


(Bhaltair Gruamach) #2

This is definitely a bug.


(Jordan Rapp) #3

Jim,

 

You can do this. When you hit a free-ride block, another set of arrows shows up both in the on-screen control panel (up-arrow on mac/pc // tap screen on ios). Unfortunately, these look exactly the same as the FTP bias control buttons that are right next to them. 

You’ll also get this second set of buttons on ZML.

When you tap up/down, you’ll see a vertical orange bar on the right hand side of the HUD fill in.

This is the same as if you just turn erg mode off during any part of a workout, which is all that is happening during a free ride block.

Ride On,

Jordan 
Zwift Game Design


(Gerrie Delport) #4

Jordan, 

 

Do you think you put a instruction like that into the FTP test telling people to increase or decrease the resistance using the buttons. 

 

This question come up at least once a week if not more.

Thanks for all your support.

 

 

EDIT:  sorry the comment above was supposed to be a suggestion, but after reading it again it look like i’m a  ass. :frowning:


(Jordan Rapp) #5

Improved tutorials is one of my primary goals. If you want the massive tutorial, I spent 90min (!!) talking workout mode with Nathan on ZwiftCast: https://www.youtube.com/watch?v=lkGro-oAOJY

 

But there’s a happy medium between that 90min video and where we are now. And we are working on it! I promise!

Best,

Jordan


(Gerrie Delport) #6

I saw that video live, it was very interesting. (my question was @ 11:23 in that video) :slight_smile:

I realize you are working on these things. I have been answering this questions a lot of times here and on FB, but I was not 100% sure it is correct since I don’t have a trainer with erg mode (mine is always in manual mode during workouts), but you confirmed my method in your video. 

 

Keep up the good work Jordan.

#rideon


(Jim Fowler) #7

I tried to use those buttons in ZML and they did nothing for me. I’ll try it on the main screen next time, but I’m getting tired of taking 20 minutes to get to the point where I test something that ends up not working and wasting my time.


(Bhaltair Gruamach) #8

“I tried to use those buttons in ZML and they did nothing for me”

 

This was also my experience.  No resistance in the Free Ride portion of the FTP test and the up/down buttons did nothing. 

I “fixed” it by restarting the workout, messing with the up/down buttons during the ERG portion of the workout, and skipping ahead to the actual test portion.  After that process the trainer provided some resistance that could be adjusted with either gears or the up/down buttons.

This is definitely a bug.  Perhaps specific to Wahoo trainers…? (I have a SNAP).


(Gerrie Delport) #9

Do you see the orange bar move when press the buttons.

 


(Bhaltair Gruamach) #10

Yes.  The orange bar moves, but it has no effect on resistance. 

I started the short FTP test, skipped ahead to the 20 minute test portion, put my bike in its biggest gear, and pressed the up arrow to max.

Above image with max resistance. Not more than tire alone.

Then I used the down arrow and lowered the resistance to near minimum.

Above image with low resistance.  Sorry the orange bar is almost faded out - I wasn’t quick enough on the camera button.


(Jordan Rapp) #11

Hi all,

I tested all FTP tests in the game and was not able to reproduce this on a KICKR (direct drive, not snap). I realize that’s not a great answer for those who are having problems, but right now, this is not a generally reproducible bug. Definitely not saying you all are not experiencing it, but it is also not universal.

How are you all paired to your KICKRs? Bluetooth? ANT? If ANT, are you connecting via FE-C? If not, try that. Make sure you have the latest firmware on the KICKR and also make sure it’s not paired to anything else - eg Wahoo app on your phone as that can impact our ability to control it.

//Jordan


(Bhaltair Gruamach) #12

I’m using ZML.  No other apps are active on either the phone or computer.  If I’ve used the Wahoo app for a spin-down or something, I not only quit the Wahoo app, but turn Bluetooth off and back on again before starting ZML.

I have not encountered any problems with Zwift resistance control other than in this specific scenario. 

Note that even though there is no resistance control during the “ftp test” Zwift is still reading power from the SNAP, cadence from my Wahoo crank-arm sensor, and heart rate from my Jarv chest strap.

Resistance control works just fine during the ERG controlled portion of the workout.  Power/resistance demanded by the trainer is appropriate to the power required by the workout.

Also, please recall that I noted above that if I adjust the difficulty using the up/down arrows during the ERG controlled portion of the workout, when I get to the free ride “ftp test” portion of the workout resistance is nominal and can be adjusted with the up/down arrows.  Using the up/down arrows during the ERG portion of the workout seems to “wake” something.


(Jordan Rapp) #13

Bhaltair,

Are you using ZML as a Bluetooth bridge to connect your trainer to the game? If so, I will try that in test to see if I can repeat this behavior.

Thanks,

Jordan


(Bhaltair Gruamach) #14

Yes.


(Jordan Rapp) #15

Bhaltair,

We tested this setup and were not able to reproduce it as described. IF we connected the trainer as the power source over ANT and then connected it as a controllable trainer via bluetooth on ZML, then we were able to reproduce it, but when the trainer was paired as both power source and controllable trainer over the same ZML connection, it worked as described. Can I ask you to open a ticket with support so that we can collect exact information about your setup? Because based on what I have been able to determine, this is not a universal bug.

Thanks,

Jordan


(Bhaltair Gruamach) #16

Ok, I’ll submit a ticket.

At least 19 other people are reporting exactly the same fault in this thread alone.

https://support.zwift.com/hc/en-us/community/posts/115018151903-FTP-test-bug-fail

More:

https://support.zwift.com/hc/en-us/community/posts/203589493-Not-understanding-FTP-Test

https://support.zwift.com/hc/en-us/community/posts/115020321183-FTP-test-didn-t-give-resistance-when-the-test-started-

https://support.zwift.com/hc/en-us/community/posts/360000390112-FTP-Test-Failure-

https://support.zwift.com/hc/en-us/community/posts/205098136-FTP-Short-and-KICKR

https://support.zwift.com/hc/en-us/community/posts/115010734526-FTP-Test-Increasing-power