Action Bar menu difficult to pop up [1.42] [iOS] [June 2023] [SOLVED]

1.42.0 seems to have fixed the issue of not being able to ride with a Robo pacer, but it seems to have broken access to the pop up menu for messaging during rides, taking snapshot, video, etc.

I rode today with two Robo pacers and one free ride. During the Robo pacer rides I had no access to the pop up menu. I run Zwift on an iPhone, so just touching the screen gives me the pop up menu. When I’d touch the screen the only thing that appeared was orange menu button on the lower left. But the center pop up menu would not display.

During my two Robo pacer rides I noticed there were zero messages from riders. Only the Robo pacer would give the occasional message.

During my one short free ride I did not have access to the center pop up menu. But I did see one message from what appeared to be another free rider.

Here is a screen shot I took with my iPhone during one of the Robo pacer rides. When I touch the screen you can see the orange MENU icon, but the lower center pop up menu should also show up, but it’s not there.

I noted this change in behavior on my iPad, also. However, toward the end of my ride I realized that if you tap in the bottom-center of the screen (i.e. where the action bar would appear), it WILL show up.

I think a compounder to this issue/situation is that, at least on iPadOS, the Action Bar is MUCH narrower, so you really have to tap in just the right area.


I tried that. Didn’t work for me. I tried tapping all over my screen looking for the secret sweet spot. Couldn’t get the center pop up menu no way no how.

Okay. Just logged on to Zwift in the Just Watch mode. I was able to get that center pop up menu if I touched a very slender area near the bottom of my screen. I tried several taps before it finally popped. Maybe during my rides I was just not hitting the small bullseye. I’ll give it another try on my next ride. Thanks for your feedback.

This is the same sort of behaviour that I have on my touch screen monitor on PC. I have to tap and swipe up on the bottom middle of my screen.

1 Like

Thanks @Randy_Jensen and @Nigel_Tufnel for flagging this up.
The touch response seems to be the most concerning issue, so I changed the subject line to describe that more concisely.

Randy - were you seeing the chat messages in Companion app, but not the game app? How did you know for certain that other Zwifters were chatting?

I don’t ride with the companion app. I ride with the primary Zwift app. In my rides I can see messages from other riders pop up on the right side of my screen. When I type my messages they show the same way, and right next to my name in the list of nearby riders.

Thanks for the context. What I’m trying to get to is: is it possible that nobody was chatting during that particular Pacer ride? It’d be unusual, but not impossible. If you don’t use Companion, how would you know if that was the case?

1 Like

The ride in question lasted more than 30 minutes. I suppose it’s possible that no one was chatting during that 30 minutes, but I’ve never observed a complete absence of chatting from member riders in a Robo pacer ride over that period of time.

Since I don’t use the Companion app for riding then I’m unfamiliar with what I might or might not be privy to in that environment. But in the main Zwift app you do see riders submitting messages that other riders can see. It is the absence of seeing these messages that I observed.

So my Robo pacer ride today had lots of messaging. I was also able to get my pop up menu to message too.

1 Like

One mystery solved! Thanks for coming back to close that loop.

I noticed this too - def a small area at the bottom only to bring up the menu.

Also noticed another thing - bring up action bar, message, type message (keyboard appears so bumps the screen up a bit), press SEND then the keyboard disappears and the text box returns to the bottom of the screen and have to press send again to actually send it

Just want to confirm I have this no menu issue issue too on latest iPad version. Please release a fix asap Zwift, thanks.

UPDATE June 28
Zwift version 1.43 resolves this issue, and will begin rolling out to iOS devices tomorrow. Please update when it’s available to you.