5 seconds "your best" value lost

I did a workout where I clearly saw an output above 700W for 5 seconds on the “end ride” overview screen. I even earned a badge for that. (this ride and “your best” had the same value)
The next workout, that peak output disappeared, and is returned to an old value, 640W for “your best”
I’m not sure for the 1/5/20 minute values, I did not pay attention for these values.

What is going wrong here? All rides were succesfully saved.

Were you using 2 different devices for Zwift?

I do all rides with the same laptop. (Sometimes I use the companion app, sensors are always connected with laptop and I always save the ride with laptop buttons.) All other data was successfully saved in my account.

BTW; It see this happening twice, first time I wasn’t sure because I did not pay much attention to the fields.

besides of that; does the device matter? AFAIK zwift saves my progress in my account, not locally.

No, those 4 “best power” values are stored locally. GPLama has a video explaining how to get rid of them:

2 Likes

What an awful solution to save these locally!
Your best should be named, “your best on this computer”…although the computer used for swifting has completely nothing to do with my performance.
Are there any other values or counters saved locally?

And still it is not the answer to my original question, because I wanted to know why my numbers are not updated if I improve them, as I always use the same computer.

Ok, the values are 1/5/20 minute and you said you achieved 700 watts for 5 seconds, but did you exceed your previous best of 1 minute of 640?

I don’t think it saves the max value.

1 Like

My 5 seconds best was about 735W. But it is stuck at 640W.

I did not pay attention for the other values, but maybe these are not saved either. But of course these are much lower. I will check the timestamps of the files.

They’re not that accurate anyway. My “bests” in Zwift and what’s shown in TrainerRoad (from the same data) are not the same, even though I only have and use a power meter when riding in Zwift. Given Zwift’s track record with data accuracy and numerous bugs in general, I’ll give this one to TrainerRoad.

1 minute in Zwift: 334w
1 minute in TR: 348w

5 minute in Zwift: 287w
5 minute in TR: 316w

20 minute in Zwift: 255w
20 minute in TR: 248w

I don’t care about accuracy. It’s depending on so many other factors. I use all my zwift values just for a comparison. Am I improving or not. So I do care if I increase my watts. I don’t care about the value itself.

That is my issue here! Zwift is not increasing my value. I don’t want to have it at zero, and I don’t want to compare it to other software or powermeters. I just want to see the increasement I worked hard for :slight_smile:

Do you have that ride on Strava? If so, can you post a link?

Sure. I saw I even made a screenshot. I forgot already that I did that. It is linked to the strava activity.

https://www.strava.com/activities/3060157846/overview

Your peak 5 second power was 719 according to Strava. I don’t know how that could be missing from Zwift. It doesn’t sound like a dropout. At least Strava recorded it for you. Sorry.

Even according to Zwift is was 723W, as can be seen in the screenshot. It is not clear to me why this particular result was not saved. I will try what happens if I only remove some of the files in the CP folder.

Problem solved?

I have somewhat of a similar issue. My 5s wattage isn’t showing at all.