Zwift won't upload media to strava

I’ve tried disconnecting and reconnecting, checking settings for Zwift and Strava and nothing has worked so I don’t know why Zwift soes not upload media to strava. The media is uploaded to Zwift Companion app but won’t appear on strava.
Thanks for any help

Hi @D_Horne
Shuji at ZwiftHQ here.

By this - I trust you mean that you’ve reconnected Strava on the Zwift end of things per these instructions?

On the Strava end, it’s worth confirming if you’ve checked “Partner Integrations” (vs the My Apps tab). Those are 2 different settings, and not super obvious.

Would you check for that in your Strava settings and get back to us if that fixes it? TIA.

Hi @shooj, thanks for the response.
Yesterday I tried disabling and reconnecting Zwift integration on Zwift and Strava’s end and my ride today still did not upload with media dispite the activity on Zwift companion app having 3 photos attached.

Hi @D_Horne, Thank you for following our steps and letting us know the results. You are amazing!
Fernanda here, part of the support specialist team at Zwift.

I would like to suggest to please make sure you have Video Sharing enabled in your Zwift Settings, and make sure that Image Uploading is set to Always in your Zwift Settings.
image

Also, I took a moment to review your account and you are running the Zwift App on a PC, is it possible for you to verify that OneDrive is not running on the Documents folder, this impact directly the upload of the media to any third-party App, personally, this did indeed proved to be a factor.

Keep us updated on your progress!

HI @FernandaA,
I took a look at my Zwift settings first and Image Uploading is set to always. I also looked through my OneDrive files and my Documents folder is in my OneDrive however the images and videos Zwift takes are not saved to my Documents folder. Images are saved to OneDrive\Pictures\Zwift, and videos are saved to OneDrive\Videos\Zwift. I have never had issues with media not saving to those files, but they never upload to Strava.
Thanks