Zwift update dramatically draining iphone battery plugged in

I have been running Zwift on my iphone 8 (with latest update) for 5 years without issue. The recent Zwift update has my phone battery draining at a rate of 30%+ even with the phone plugged in. Nothing else is running on my phone and I have tried several different cables. Zwift is also making a repeated beeping sound (connection?), despite phone sound being off. No other app drains the battery like this, bluetooth works well with all other connections, no power drops while using Zwift (or other issues). This started last week with the latest update which changes the initial interface of selecting a ride, etc. Any suggestions for how to fix this would be greatly appreciated!

Hey Mara.

Perhaps someone else will chime in with suggestions but I’ll put out there that this may just be a combination of a phone with an aging battery + Zwift being quite processor intensive.

The repeated beaping sound might be a clue though: I used to get that when I had a poor connection to the charging cable. Since you’ve tried different cables, another possibility is a bad charging port - they can get worn out. You might also try a different wall charger if you haven’t already. The iPhone 8 also has wireless inductive charging so it’s worth trying that with a fast charger to see if it delivers more power than wired charging. (which would further suggest an issue with the port)

If you could post a video (with sound) of the recurring beeping, that might help us track down the source.


Hey CJ, Thank you for the response! The battery is actually new, replaced about 6 months ago. I realize my iphone 8 is not new but it has been running Zwift without draining the battery at all (phone plugged in while using) until the past week; now it is draining about 30% per 90 minutes, before it would hold the full charge while plugged in. When I check the battery usage it shows Zwift Audio(? I would think it would be the video?). I have the sound turned off so I am not sure what is running, but it seems that some additional feature is running on Zwift. I will try to get a video of the sound to post (ran it again today, no beeping). I have checked the Bluetooth connection and that seems to be fine too. I will check the port and try a different wall charger, I have had it plugged into my laptop which is plugged in, but will try a different set up. Thank you for the ideas! Will keep trying!

Quick follow-up: have you had any luck troubleshooting, Mara?

Hi CJ,

Yes, I did have success! I cleaned the port on my phone, tried a 3rd cable (not apple but newer, faster charging cable), and plugged the phone into a wall outlet instead of my laptop. I also turned off all sound in Zwift, my phone battery usage showed Zwift Audio is the battery use.

My phone maintained a 100% charge for my entire 2+ hour zwift ride (workout).

Thank you for the suggestions! Much better than having to replace my phone, which I know I need to do soon.