Zwift requires .net 3.5 and I can install it


(Rob Woolfson WCR) #1

I recently upgraded my laptop to Windows 10 and it comes with .NET 4.5 but 3.5 is not supported.  When I try to use Zwift it keeps trying to install 3.5 but fails.

Is there a way round this?


(Steve Ellis) #2

Here are some pointers from Microsoft: https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10 


(Paul Allen) #3

Steve,

That is a dead link.

Rob,

Try this link: https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

It’s very easy to get .NET 3.5 on a Windows 10 computer.


(Rob Woolfson WCR) #4

Trust me that did not work.

I kept getting an error saying that it couldn’t find the installation files

In the I found a downloadable software installer.

All its working now


(David Kindler) #5

I have the same problem… can’t find the files to install…where did you locate .NET 3.5 files to get Zwift running?   I’m running a relatively new Dell Latitude with Win 10.

 

thanks


(Paul Allen) #6

David,

Have you tried Control Panel>Programs and Features

On the left side click on Turn Windows features on or off 

The first one should be ,Net Framework 3.5

Also, try this link: https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10

You could also try this:

DISM /Online /Enable-Feature /FeatureName:NetFx3 /All /LimitAccess /Source:d:\sources\sxs

 

Where the Source:d was the dvd I used to do the tech review installation (d: should be the drive with the windows 10 tech review installation software)