Zwift Mac OS no longer maximizes screen

after a recent update Zwift seems to scale to no longer taking up my whole screen. I have to manually drag out the corners each time (it used to remember its state upon relaunching) , not sure if this is a known bug. First pic is how it is now, second is how it used to be. This is not “full screen” mode btw. Just stretched all the way out

This is Zwift shifted the mac app to metal, so this is not a bug.

I believe the green button at the top of the window on left will make it full screen so you don’t have drag it.

1 Like

apologies as I’m not super tech savvy but that means this is now the default behavior? any way to change it ?

I don’t know if there is any way to change the default. But yes, this is now the default.

Isnt there a “full screen” or “windowed” setting available in the settings menu like on windows PC?

I’ll play with it. Macs full screen takes over so I prefer not full screen but with the window maximized for size if that makes sense