Zwift laucher out of date

I try to start zwift this morning: Error - zwift launcher out of date…

can I manually update zwift ?
Really shitty timing to get this error tbh.

Thx

If i click ok, it says, error retrieving link.

deinstall, reinstall?

Nope, tried that. And the Installer is a small file, which needs an update. And the update is not working

Today it works fine btw. So problem solved.

So I think maybe a small server problem or bug?

I have the same problem