Zwift Hub One - no virtual shifting during FTP

Hi all,

I have a newly purchased Zwift Hub One and Zwift subscription. I’ve done a normal ride using the virtual shifter which worked no problem.

I then tried the 20 minute FTP test. It starts out working fine - I can use the virtual shifter to alter the effort percentage. However, when it got to the actual 20 minute test, the virtual shifter would not change the resistance at all. I could see the gear number changing in the UI but it had no affect at all (on gear 25 I would spin out and not get above 130W).

Anyone else experienced this?



Hi Mark,
yes experienced too, but i have no idea why.
Greetings Rene

Yes had my hub one about a month and exactly the same issue.
Tried the full test and today the short one, get to test fine and then no resistance gearing changing on screen but resistance doesn’t and i sit at about 115w.
Very annoying
Thanks rich

Hello @Mark_Beverley @Rene_Hellmann and @Richard_Wood1 welcome to Zwift forums and Zwift more broadly.

What you’re describing - that the trainer doesn’t respond to shifting inputs during a structured workout - is expected. You’re in ergometer mode (aka ERG mode) during that 20 minute FTP test, or any other structured workout.

If you’re using a smart trainer, your only job is to hit the pedal cadence target shown on the heads up display. As you change the pedal cadence, the trainer automatically adjusts your resistance so that you can hit your wattage target. More information about ERG mode here.

There’s no power target in a 20 minute FTP test free ride segment. Shouldn’t shifting be functional in that context?


Exactly this. @shooj how can this issue be escalated?

I will try a capture it on video later. I’m guessing if I try the below FTP test it will start with non-ERG mode so I won’t have to go through the whole thing before the issue shows up?

Yes the ramp test starts with a free ride segment but the important part is typically done in ERG mode with no shifting.

I believe this is wrong. For the OP’s info, erg mode is when the trainer tries to keep you at a certain average power. You just pedal and it adjusts the resistance. Workouts do default to erg, as you said. For the 20-min FTP test, if you set erg mode on, the warm up blocks are obviously in erg mode. You can do a workout with erg off, and then you have to hit the power target yourself (the display flashes at you if you’re too far above or below).

However, the actual 20-min portion is a free ride block. Erg mode is off. Zwift does not auto adjust the resistance. We may need to adjust the trainer resistance in these blocks!

In workouts, if you turn erg mode off, the workout panel has a setting to adjust the trainer resistance. This is true for all trainers. I don’t remember what happened for my last 20-min FTP test, but I would expect that setting to still work. So, the OP should check. Go to the companion app, and look at the workout screen.

That said, I would intuitively expect the Zwift Hub’s shifter mode to work in that setting.

As a quick update, I did the ramp test and that worked as expected. So either the issue is intermittent or is specific in some way to the 20 minute FTP test.

I will try and do that one again at some point. I’ll also try as Weiwen is suggesting and turn ERG mode off when it gets to the free ride portion.

1 Like