Zwift ERG not working with training programs

Been using my tacx neo for years and never had issues. I just got a brand new Kickr Rollr this month. The first 4 rides worked great. I paired it with my Favero assioma pedals for power and ERG worked just fine.

the fourth ride I tried, erg no longer works. It functions like a normal, non-smart trainer/roller. I’m using zwift through my phone (android). I did some searching on the forum and saw someone had a similar issue but was zwifting through PC. One of the Zwift support staff (mike) had provided some steps to resolve the issue but it seemed like it was through PC as they had to download certain files. Not sure if the same steps would apply for me using the phone app.

I can’t remember for certain, but I may have had to update the zwift android app before i rode today. version 1.57.3

Hi Jason,

A common cause for this is signal interference, where another device or app is diverting your device’s signal. Check out our BLE and ANT+ Interference Troubleshooting Tips for some steps on how to resolve it.

With Android, there could be some workout apps running in the background (e.g. Wahoo, Companion) still connected to your Rollr. Force closing them can help resolve this issue. To force close Just follow these steps:

  1. Open the Settings app on your phone.
  2. Select Apps.
  3. Select any workout app such as Wahoo, Companion, etc.
  4. Select Force Stop.

If you’re still having issues, please reach out to us at and we’d be happy to help you.

Hi there,

I am experiencing the same issue, ERG mode not functioning in work out mode, the resistance does not change. I am in week 8 of the Build up training plan and everything worked fine up until about 2 weeks ago.

I am using the iPhone app directly with BT. I also use Wahoo System app and ERG mode works with that app no problem. I have tried all the usual troubleshooting but nothing seems to work. Any suggestions?

iPhone: 17.4
Zwift app: 1.59.0
Trainer: Stac Zero