Zwift Companion Release: August 10th (3.17 iOS, Android)

:slight_smile:

You learn something new every day…

Thanks, I will give it a try.

1 Like

I’ve pressed everything to see if I can reduce to one … I havent found that one yet :slight_smile:

Hi - yes, still having crashing. I’m on Android 5.1.1 on a Sony phone. Thanks.

The companion app is behaving differently for me now since downloading the 3.17.1 patch.

I currently run Zwift on my PC in my house and cast my screen via Chrome to the garage. I use unified remote as a wifi mouse to start the ride, navigate menus etc. Now, if i switch to this app, or any other, i lose all connection to my sensors.

Before this patch I could happily switch between apps on my phone without issue. Version 3.17 worked perfectly, 3.17.1 has broken this.

1 Like

May be unrelated but I noticed my phone with Companion app active really not play nicely with my internet radio remote app tonight, which runs in the background. Kept dropping WiFi and made my phone unresponsive repeatedly. Like it couldn’t handle both running at the same time, which has never been an issue before. Also on 3.17.1.

It’s an odd one, both my wife and I had the same issue using our own phones. Both on 3.17.1.

I have now reinstalled the companion app and seems to be ok, it’s a billion degrees this evening so going to try it properly tomorrow now

1 Like

Just reinstalled and it was a weird process - it installed 3.17 and so immediately said there was an update available (the app crashed on trying it, as before the patch). Uninstalled, tried again and this time it installed 3.17.1 directly. So I’ll give that a go, in case patching was what caused my unresponsive issue.

Just been promoted to download 3.17.2 on Android. What’s changed/been fixed?

I’ve been having issues with connecting sensors and keeping them connected since 3.17.1

Just downloaded - now I cant get the game loaded as if it was on the wrong network. Its not as the pc is hardwired. Re-installed/rebooted. No go. Still get events.

So tried another PC (wired) and another phone - same result, it doesnt see the “game”.

Running it for a few minutes to see what the logs say

5 minutes and phone wont connect. Sent log to Zwift mothership. Also get errors on app that I have only seen once before (but tonight it keep coming up).

That’s really odd.

I use mine on a mesh network, PC is hardwired in house to router 1. Phone connects to garage via WiFi on router 3. Up until now this has been perfect.

Since update, companion and zwift app on pc seem to not talk to each other very well. Ending ride on companion app for example doesn’t actually leave the ride in the zwift app. Sensors disconnect and then can’t be found requiring a full restart of zwift.

Also Garmin cadence sensor simply won’t connect at all. The sensor has good battery and connects without issue to my Garmin edge but cannot be found by zwift companion.

Edit: also run the same setup but with pc on WiFi. Also brought sensors into the house HRM and cadence, won’t connect via companion. Will connect direct to PC Bluetooth though…

Mike:

Has your Garmin cadence sensor ever connected to Zwift Companion? I believe ZC requires Bluetooth, and most Garmin cadence sensors in use do not have Bluetooth. Your Garmin Edge is picking up the ANT+ signal from the Garmin cadence sensor.

Yes it is the newer version with BLE and ANT+.

It has worked without issue up until 3.17.1

Same with me, using my zwift on mac also have other issue

3.17.2 is now working but somethings up.

Woke up this morning and gave everything another go (2 different pc’s and phones and pc’s all hard wired). Turned everything off/on.

Getting the same problem. including error on CA shown above on both setups. I could clear the error, get CA data, then the error would come back.

I then switched to 2.4ghz and it worked. Switched back to 5ghz and it worked. Thinking maybe Zwift app was polling for different phones, nope, same ip/port.

Dumbfounded, but will take it is a gremlin somewhere that has worked itself out.

Yet to try decent ride but I suspect I will be good to go later tonight, though your issues, @Mike_D7, have me a tad anxious.

Oh, and I can report that the 3.17.2 update does not fix my mini-map problem.

My wife successfully connected everything for her ride earlier with 3.17.2 so perhaps the problems are behind us. I’ll try again tomorrow

1 Like

First time user, pixel 4 XL
The app won’t recognize my ID/PW combo. Since others can log in, probably not an issue with this version. But reporting just in case.

Just checking but your ID will be the email you signed up with.

Failing that, try a password reset

Companion app running in treacle today, Android 10. Anyone else? Pixel 4 and 3XL, same issue