Zwift 4K on a Dell XPS8920 with GTX1060

Hi Guys

Hope you can help me.

I’m new to Zwift on PC (was using iOS previously), and just getting set-up.

I’ve taken delivery on a new Dell XPS 8920 and a 4K screen.

I thought this PC would be easily enough spec to power 4K resolution, but the highest setting i’m seeing in Zwift is 1080.
Is there something I should be doing to push it into / select 4K mode?

PC spec is -
Intel Core i5-7400
3.00GHz
8 GB RAM
2 TB HDD + SSD
NVIDIA GTX 1060 6GB Graphics Card
64-bit
Windows 10 Home

It’s a clean machine, no other programs or apps running, except for operating system stuff.

Any help really appreciated :o)

Michael

I’ve got a similar spec machine with a NVidia GTX 1050 graphics card and I can run Zwift in a high resolution than this. I found that the secret was to tell NVidia software to use the GTX card instead of the in-built Intel graphics card when running Zwift, and this unlocked the extra resolutions. The option is available in the NVidia control panel.

Do a quick Google search for “Zwift Nvidia settings” to find a few parameters to tweak too.

 

Thank you Steven, that’s good info, I’ll give it a try and report back :o)

Michael

Hiya

It turns out I didn’t need to change any settings, I had put the cable into the motherboard HDMI port, rather than the GTX graphics card HDMI port … silly me. Your reply did make me wonder whether i’d done that. Doh.
Moved it over, and hey presto, I got Ultra and 4K options appear automatically in Zwift.

4K detail is amazing.

Thanks again

Michael