Whoop connection issues

I can’t believe that I’m the first to post about this, but I can’t for the life of me find any recent posts regarding Whoop and Zwift connection issues. For years I have had no issue, but several weeks ago, Zwift (on all manner of platforms, iPhone, iPad, MacBook, etc.) completely refuses to recognize my Whoop 4.0. My first thought was that this was due to a faulty Whoop, but I have an older Whoop 3 sitting in the back of my closet that I dusted off and charged up, and even that is no longer recognized by Zwift. This leads me to believe that this is a software issue with Zwift. I have to imagine there are lots of people using their Whoops with Zwift, so again I couldn’t believe it when I pulled up google and found nothing recent about this issue.

If anyone has a solution to this, or even if you’re simply experiencing the same issue, let me know. Thanks all

Had to search the net to find out what a whoop 4.0 was

Dumb name, decent (but getting better) product.

I’ve the same issue too. Whoop 4.0 has been working fine, but tried it last week and would not connect. Confirmed it connected to my Wahoo Bolt to eliminate BLE clash or faulty Whoop.

Any feedback whether this is a bug or by design? No recent posts found though as per the OP.

Can’t rule out that it’s not unlike the Apple Watch. Worked for a while but was never a supported product and Zwift eventually dropped support.

How does the Whoop work? Does it just emit a BT HR signal much the same as HR straps do?

Similar to fitness watches, has a toggle option to broadcast HR, which should allow compatible devices to receive. It’s standard BLE I understand.

Shouldn’t really be any reason it’s not picked up but i guess without digging into the Bluetooth architecture it’s hard to say.

Apple has its own little quirk that made Zwift compatibility so potentially so has Whoop.

I guess the salient point is why it suddenly stopped working. Hopefully one of the Zwift staff can provide clarity if support for it has been officially removed.

Yeah agree. Hopefully Zwift could give some clarity on their side as to whether this is the case.

Trying also to reach out to Whoop (which is a challenge) to see if a firmware update may have caused this also…

It was a software issue. The latest whoop update fixed the issue for me.

1 Like

Confirmed… tried it on Saturday with no success, just tried it again after your reply and you’re right, all working now… must have been a delay in my auto app update. Ride On!

Great, glad it’s working.

1 Like