Weird textures


(Jeremy Summers - Minehead CC) #1

Does anyone else get this? Seems like the height of various flora is amplified for some reason! Disappears when away from grass/flowers etc…

Intel HD4000, 16GB RAM, Windows server 2012 datacenter. Maybe it’s the strange OS that’s causing the issue. I think it’s always happened on this PC despite various updates…


(Eric C. (Zwift HQ)) #2

Hi Jeremy,

This is definitely a case of outdated graphics drivers. Please refer to our Knowledge Base article here on how to address this: https://support.zwift.com/hc/en-us/articles/204920669-Updating-graphics-drivers-giant-plants-missing-text-etc-

Also moving this into Troubleshooting.


(Cory Hammerstone) #3

I was having this same issue, and now I wish I would have just lived with it.

I tried to update my graphics drivers, and all 3 of the different tools said that I had no graphics drivers. I started a support conversation with someone, and she told me that it was intel, so I tried again, and it said that I had no graphics drivers, even though I am sure this would not work without one… so I found what I thought that I needed on Intel’s downloads website, and got it and now when Zwift opens, it is only a black screen. Kinda sucks because I was really excited about getting on the bike again this afternoon but now I think I will have to take my computer somewhere- unless you have any advice for me. :frowning:


(Eric C. (Zwift HQ)) #4

Hi Cory,

Depending on the computer you have, some manufacturer’s have proprietary drivers that require you use theirs. This is especially prevalent on Dell, Lenovo, and HP laptops but it’s not ALWAYS the case.

The problem here is that they often stop supporting computer models after a couple of years and that means the drivers don’t get updated; the hardware is capable but the software is hampering it.

Contact the manufacturer of your computer and they should be able to sort it out.


(Cory Hammerstone) #5

Thank you! I will try that. I usually know better than to try to fix things in my computer. I have spent a decent amount of money learning this lesson, too!! :slight_smile: I am just anxious to get back on the bike in Watopia. It is so awesome!

 


(Eric C. (Zwift HQ)) #6

It’s definitely *not* obvious, so I don’t blame you. It was only after working with many frustrated users that we discovered the nature of these driver issues.

Good luck and please let us know how it goes! We’ll do everything we can to help :slight_smile:


(Cory Hammerstone) #7

It all worked out. As it turns out, I had downloaded a random (and incompatible) graphics driver, but then I was able to download the correct driver and everything works like a dream! Still loving Watopia!! Thank you so much for the quick response. 


(Jeremy Summers - Minehead CC) #8

I got it all sorted too thanks Eric. On the server OS I had to download the zipped driver rather than the .exe from Intel (the auto-detect tool didn’t work either).


(Eric C. (Zwift HQ)) #9

Great to hear, everyone! :slight_smile: