Wahoo Tickr - Lower than expected BPM readings

… I tried … maybe a little better … maybe the same …

UPDATE – After a quick email exchange with Wahoo support, they’ve sent out a replacement Tickr via UPS.

To anybody still experiencing this issue, I’d recommend sending a support ticket to Wahoo.

1 Like

Thanks for the tip, I opened a ticket too!

Ok! They will send me a replacement band. Then, based on how it goes, we will see what to do. Excellent assistance.

Resolved!

1 Like

Have to say I was hoping for a Zwift side resolution to this, but, things seem way more stable as of late. I still notice a rise in BPMs when I sit up straight, but, I think I may just have to live with the discrepancy.

Had this flat lining for the first time ever tonight with my Tickr over ANT+. I’ve owned it for over two years. It recovered about five minutes into the race and worked correctly after that.

How would Zwift be able to resolve this, surely they are just displaying whatever the hrm is sending.

I’ve been having this problem too. Very frustrating. I will try to contact Wahoo-- hopefully they can address it!

Wahoo replaced my Tickr X. At first, they thought it was likely a strap failure, and they sent me a new, redesigned strap. That didn’t solve the problem of my Tickr improperly smoothing my HR, so they sent a replacement unit. That unit appears OK, for now.

In the past, I would frequently get my heart rate smoothed at 122-124 BPM. The HR line was jagged, so it wasn’t simply displaying 122 BPM constantly, but I checked my HR contemporaneously on my Apple Watch, and there were numerous times I verified that my actual HR departed from my reported HR. Then more recently, my Tickr would return a HR reading for a few minutes (sometimes a correct reading, mostly not), then it would go to a constant 225 BPM for the rest of the ride.

Using my third Tickr-X. (First X-2). Same issue, random spikes, drop-offs, erratic behaviour, stuck on low readings etc, on both ANT+ ad BTLE channels.