Wahoo kickr v5 firmware upgrade fails

Try to upgrade to latest firmware but get error when trying from wahoo app on Android phone.
Only me? Or knows any workaround?

Says “the required firmware file was not found in the downloaded firmware package”

Tried both with and without the Dircon adapter conneted. Restartes app and the trainer multiple times. :cry:

I got the same message. (Android phone)
So you are not alone.

Firmware v4.3.0 failed from my Android phone but worked when i used my iPad. Will probably work from any Apple product untill Wahoo resolves the Android issue.

Updating the firmware failed for me as well. I’m on android 13. The message was something like “did not respond in the time expected”.

Comments on the recent Zwift Insider article indicate that this is a problem with the Wahoo app on Android 13 and the current workaround is to use something else to update it.

Thanks @Paul_Southworth

I’m on Android 10 btw

Thanks Paul. I’am using Android 12.
I have a old phone with Android 9. Maybe that works, i must test it.
I dont have Apple phone or tablet. Only Appple TV but i dont think the Wahoo app wil run on it.

EDIT: Fails also on Android 9

Come on Wahoo! I’m dying of abstinence here!

Girlfriend saved the day, she updated my Kickr for me with her iPhone :upside_down_face:

1 Like

I used an old iphone6 from a friend to update the firmware.
The last version of the Wahoo Fitness app needed at least ios13.
So i needed to install the app first on a recent iphone with my account.
Then i could install the app on the iphone 6 from the icloud. This was a older version of the Wahoo Fitness app. But it let me install the firmware.