Wahoo Kickr Core Erratic Resistance and Power Readings

What I’m using:

  • Wahoo Kickr Core
  • Windows laptop (via Bluetooth)

This started happening around January. I’m not sure if it was due to the virtual shifting update on Zwift or the software update on the Wahoo Kickr Core trainer. Note that I do not have Zwift Click nor Zwift Play so I’m assuming that virtual shifting is disabled (I don’t see it in the settings anyway).

Things that I experience:

  1. Incline in-game is more than 0% but there is no resistance from the trainer. If I pedal through this, power reading will show 0 watts until resistance kicks in. This usually results to the second one.
  2. Resistance from the trainer is a lot heavier than the incline shown in-game. If I pedal through this, power reading will be a lot more than my actual output. Even if I stop pedaling, the watts keep going up for a couple of seconds.
  3. If it’s neither of the two above, the resistance is random. It keeps on changing until any of the two situations above kick in again.

I’m not sure what causes this, but I know it started happening after the virtual shifting update. It might be the auto-calibration thing too, I don’t know. Back in January, factory spindown fixes this for a few rides until it starts happening again. I did a factory spindown yesterday and tried to race again today. Everything was fine until the 14-minute mark. It didn’t even last a whole ride. I already reported this to Wahoo but I’m posting it here too just in case anyone has experienced and fixed this.

I managed to take some pictures after it happened a while ago.
Explanation:

  • 1st-3rd pic - I was spinning but it showed 0 watts.
  • 4th pic - Resistance suddenly became very heavy, thus, resulting in lower cadence. It still showed 0 watts.
  • 5th - 6th pic - I continued pedaling through the resistance and it showed some power.
  • 7th - 8th pic - I stopped pedaling already but there are still power readings and it even increased.








Did you also install the firmware update that came out in March?

The recent one, yep! I believe it’s v1.4.8.

Flawless 32nd level Android User since 2020. In the last 3 months my Kickr Core became erratic and would not register speed, cadence, or resistance consistently. It spikes and then decreases to the point of not being able to use it.

Suspecting a hardware issue, my back and forth with wahoo has been unproductive despite seeing this forum loaded with examples of issues between the kickr16 hardware and Zwift. They have been unresponsive on replacing the 3-year-old unit in which I spent full retail at the time…$1,200. My wahoo app works perfectly with the kicker but no longer with Zwift. Tragically, unless I can find a fix I will have to abandon this platform that I have truly enjoyed. I’m extremely disappointed with Wahoo.

Everyone references finding out if your kicker is connected to another device via Bluetooth. I have confirmed and verified there are no other Bluetooth devices in my home that could be connected to it so I got to believe this is software. Especially since wahoo app is working just fine.

Open to suggestions. Thanks.

have you updated to latest firmware yet? I had similar issue in January when after a game update resistance started to jump around. was bit strange since trainer did behave differently at BT & ANT connectivity. Manual spindown finally fixed it which is automated w/ latest firmware.

Came back again after a couple of rides. This is getting annoying already. Does anyone have a fix?

I’ve been experiencing this as well and it’s getting frustrating already. Manual spindown is just a temporary fix for me because it keeps coming back after a couple of rides.