Very poor graphics despite Ultra capable system

Yes, seems to be ram related bug… either way there’s nothing you do about it! Its zwift coding team that have to resolve this one.

Thanks, again an unusual RAM capacity (would normally be 16384MB). Can you just confirm a couple of other things please? One is a screenshot from analysis of a log file at, and the other a screenshot of the memory page in Resource Monitor in Windows (type it in your start menu).

1 Like

Thanks! So Resource Monitor shows the right about of installed RAM this time but again Zwiftalizer confirms that Zwift is not recognising it at all. Surely it’s got to be to do with that.

This is from my Pentium Gold laptop with Basic profile on integrated graphics at 1080p, and the textures are noticeably clearer.

So lets check if I understand the problem correctly… If i remove one ob my 8GB ram my graphics will be much better? 16GB is not working while 8GB should?

good news this morning. I do not know if it was zwift which made a correction but my textures are now magnificent.

I updated the bios of my motherboard for the F51 version (Gigabyte B450 Aorus Elite) maybe the problem came from there?

Now from zwiftalyzer my memory appear.


Great news! I wonder if they fixed it in the latest update? BIOS update could make sense too though, if it means Zwift can now see the RAM correctly.

Edit: same game version on your two Zwiftalizer screenshots, so unless it’s a change at Zwift’s end it can’t be the update.

I’m not sure that will help, and then you would be in single channel mode which damages performance. The problem seems to be that Zwift isn’t recognising any RAM at all on some PCs. Though maybe it’s fixed now, looking at the above? Give it a try on the new Zwift update.

Edit: think he solved it with BIOS actually.

New update didnt solve the problem. I need to check for the bios update. If there is an update I will report if that worked.

There is (F50), but I believe the OP has already tried it.

I see that now. I can try to update it anyway but I dont expect that will resolve a problem.

Yes. I’m on the newest BIOS for my B450M mobo, which is F50.

Our F50 version of bios deosn’t work. Samuel_Leguevaques has F51 version (relese notes: Improve system compatibility) and that works.

I am still waiting for the new bios version but at the moment F51 is not avaliable.

Or maybe they can fix something with zwift update?

Did you update to F50 anyway?

1 Like

No. When I saw that Michal_Wozniak has the new version of BIOS (and the same mobo) and that still didn’t solve the problems I decided to stay on the safe side :slight_smile: I really need a functional computer in corona time :smiley:

Reason I ask is that the difference between Michal’s system and yours is that he’s on Zen+ and you’re on Zen2. So you may find a BIOS update does actually work for you. I understand your worry about bricking it though!

Edit: you’re also currently on a BIOS version that was known at the time to be a bit unstable, that’s why your version (F42b) isn’t available to download any more (it’s been replaced with F42h).


Omg. That worked. I updated to F50 version. There is now 16384MB RAM detected. Zwift now loads the textures correctly. Also Zwiftalizer now shows 16GG RAM.

Real 4K zwift is much nicer :slight_smile: Tnx for the support and suggestions!


Woo! Happy days.


Oh yes a good thing !!!

Enjoy Zwift

1 Like

I guess I will be last man standing with abysmal Zwift graphics :wink: