Update required

Updated required to ride. I go to update within play store. Wait not update WTF. Can’t use app.

Uninstall app and load latest version. RESTATRED PHONE. Still update required. WTF.

Software last updated on 25th August automatically. Version 1.16.1 (79337).


Starting look for another app

I just loaded the latest version on my Samsung galaxy S21 and it worked as expected. Latest version is 1.16.2 (1.0.80068) (Sep 2 2021). Updated as usual, no reinstall or any issues.

I guess you need to


Rod_Stokes, I understand your frustration

I was having the exact, same issue. I tried to open Zwift and it required me to update. I clicked “UPDATE.” When Google Play opened I had 2 options: “Uninstall” or “Open.” I clicked “OPEN”; Zwift said I needed an UPDATE. After going back and forth on this several times I began to feel like the butt of an elementary school joke, “How do you keep a moron busy? Turn this page over.”

I was able to update immediately on my computer.

I did just now uninstall and reinstall the app on my phone and it did work. I hate to suggest trying it again - but that’s what I’m suggesting - give it another chance. Hope you are able to get it resolved.


Unfortunately Zwift can’t control how soon the app updates appear in all the regional App Stores and Play Stores once they’ve released those updates to Apple/Google.


Same issue at my end. No update available in the Play Store, tried an uninstall and reinstall, restarted phone, still no go…